summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-11-28 12:26:32 +0100
committerLudovic Courtès <ludo@gnu.org>2022-11-28 12:26:32 +0100
commit459e4f2a4f2b16daded2aaba20edf3fffa4095f3 (patch)
treed1e2ada4dcfde3d3b4119087550c26856b42dbcf /gnu/packages/machine-learning.scm
parenta3264f31df9774ea514e18ed8e7b6bcb44061edc (diff)
parente6bffa99b19fe01067937a4930f1b107bd0ac398 (diff)
Merge commit 'master' into version-1.4.0
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 61b0400715..fbc06f96b6 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -3224,18 +3224,14 @@ Python.")
(define-public python-hmmlearn
(package
(name "python-hmmlearn")
- (version "0.2.6")
+ (version "0.2.7")
(source
(origin
(method url-fetch)
(uri (pypi-uri "hmmlearn" version))
(sha256
(base32
- "1my0j3rzp17438idr32ssh0j969a98yjblx5igx5kgiiigr9qa1a"))
- (snippet
- #~(begin
- (use-modules ((guix build utils)))
- (delete-file "lib/hmmlearn/_hmmc.c")))))
+ "1qgnf1kdxicygy8nvpv866iqvwq0rc6xkd3s6slmvxvsy8h2fjvb"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -3247,7 +3243,11 @@ Python.")
(with-directory-excursion (string-append (assoc-ref outputs "out") "/lib")
(invoke "python" "-m" "pytest"))))))))
(propagated-inputs
- (list python-cython python-numpy python-scikit-learn python-scipy
+ (list pybind11
+ python-cython
+ python-numpy
+ python-scikit-learn
+ python-scipy
python-setuptools-scm))
(native-inputs
(list python-pytest))