summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-03-25 16:32:19 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:12:14 -0400
commit0c00fea3c2b74991102e59f748285ac21b1de16e (patch)
tree52652ad954f4c91e091b17cf329d677130ce07fe /gnu/packages/machine-learning.scm
parent8403c593285ea99cc3482ab68ba9525864803388 (diff)
gnu: Add python-sentencepiece.
* gnu/packages/machine-learning.scm (python-sentencepiece): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index f7f5bcd954..70319238d9 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -675,6 +675,25 @@ SentencePiece allows us to make a purely end-to-end system that does not
depend on language-specific pre- or post-processing.")
(license license:asl2.0)))
+(define-public python-sentencepiece
+ (package
+ (name "python-sentencepiece")
+ (version "0.1.97")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sentencepiece" version))
+ (sha256
+ (base32 "0v0z9ryl66432zajp099bcbnwkkldzlpjvgnjv9bq2vi19g300f9"))))
+ (build-system python-build-system)
+ (native-inputs (list pkg-config))
+ (propagated-inputs (list sentencepiece))
+ (home-page "https://github.com/google/sentencepiece")
+ (synopsis "SentencePiece python wrapper")
+ (description "This package provides a Python wrapper for the SentencePiece
+unsupervised text tokenizer.")
+ (license license:asl2.0)))
+
(define-public shogun
(package
(name "shogun")