summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-06-27 00:22:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-06-29 12:01:21 +0200
commit1e9a59bb5487b084854ccb39f7482797c5f9fc5d (patch)
treee47faf913da1d2180c27754b831e673669e71986 /gnu/packages/machine-learning.scm
parentb24a05830d11e3011eee4bc5f60a41e26188cde1 (diff)
gnu: python-threadpoolctl: Update to 3.1.0.
* gnu/packages/machine-learning.scm (python-threadpoolctl): Update to 3.1.0. [build-system]: Use pyproject-build-system. [arguments]: Remove custom 'check phase. [native-inputs]: Add python-flit-core.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index e1b26e69c3..755fe08b33 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1471,26 +1471,17 @@ with your favorite libraries.")
(define-public python-threadpoolctl
(package
(name "python-threadpoolctl")
- (version "2.1.0")
+ (version "3.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "threadpoolctl" version))
(sha256
(base32
- "0szsxcm2fbxrn83iynn42bnvrdh7mfsmkhfn8pdn7swblfb7rifx"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest"))
- #t)))))
+ "100k76nmajf408lbn5ipis1gilklcs6sbqyqy3hhlh54zanbldd3"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-pytest))
+ (list python-flit-core python-pytest))
(home-page "https://github.com/joblib/threadpoolctl")
(synopsis "Python helpers for common threading libraries")
(description "Thread-pool Controls provides Python helpers to limit the