summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-03-25 16:32:18 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:12:14 -0400
commit8403c593285ea99cc3482ab68ba9525864803388 (patch)
treebce5429a2c1920ea98f131f9eda9e45157e093e8 /gnu/packages/machine-learning.scm
parent48a1ed92f620aa343b44ad2b00bac67f341cbab8 (diff)
gnu: Add sentencepiece.
* gnu/packages/machine-learning.scm (sentencepiece): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm19
1 files changed, 0 insertions, 19 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 70319238d9..f7f5bcd954 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -675,25 +675,6 @@ SentencePiece allows us to make a purely end-to-end system that does not
depend on language-specific pre- or post-processing.")
(license license:asl2.0)))
-(define-public python-sentencepiece
- (package
- (name "python-sentencepiece")
- (version "0.1.97")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "sentencepiece" version))
- (sha256
- (base32 "0v0z9ryl66432zajp099bcbnwkkldzlpjvgnjv9bq2vi19g300f9"))))
- (build-system python-build-system)
- (native-inputs (list pkg-config))
- (propagated-inputs (list sentencepiece))
- (home-page "https://github.com/google/sentencepiece")
- (synopsis "SentencePiece python wrapper")
- (description "This package provides a Python wrapper for the SentencePiece
-unsupervised text tokenizer.")
- (license license:asl2.0)))
-
(define-public shogun
(package
(name "shogun")