summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-09-09 14:31:47 +0000
committerLudovic Courtès <ludo@gnu.org>2022-11-22 23:17:06 +0100
commitbddb43b422cb71679be6176dda91e45b6e6f3971 (patch)
tree46352dd15129be5574b9bd4ab7547d1a8fbce7f5 /gnu/packages/machine-learning.scm
parentca428f944fa61c63de252af6cc88dd815c074a0f (diff)
gnu: python-hmmlearn: Update to 0.2.7.
* gnu/packages/machine-learning.scm (python-hmmlearn): Update to 0.2.7. [source]<#:origin>: Remove deletion snippet for file removed upstream. [propagated-inputs]: Add pybind11. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 61b0400715..fbc06f96b6 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -3224,18 +3224,14 @@ Python.")
(define-public python-hmmlearn
(package
(name "python-hmmlearn")
- (version "0.2.6")
+ (version "0.2.7")
(source
(origin
(method url-fetch)
(uri (pypi-uri "hmmlearn" version))
(sha256
(base32
- "1my0j3rzp17438idr32ssh0j969a98yjblx5igx5kgiiigr9qa1a"))
- (snippet
- #~(begin
- (use-modules ((guix build utils)))
- (delete-file "lib/hmmlearn/_hmmc.c")))))
+ "1qgnf1kdxicygy8nvpv866iqvwq0rc6xkd3s6slmvxvsy8h2fjvb"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -3247,7 +3243,11 @@ Python.")
(with-directory-excursion (string-append (assoc-ref outputs "out") "/lib")
(invoke "python" "-m" "pytest"))))))))
(propagated-inputs
- (list python-cython python-numpy python-scikit-learn python-scipy
+ (list pybind11
+ python-cython
+ python-numpy
+ python-scikit-learn
+ python-scipy
python-setuptools-scm))
(native-inputs
(list python-pytest))