summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-07-07 14:27:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-07-08 18:41:35 +0200
commitc6136b48c2fb0c4a6521dcc923358946ec50b8d8 (patch)
tree6bdc15b2a51197e2e268442d45827c84031b0b35 /gnu/packages/machine-learning.scm
parent788ba04f386710f90a00e823d0b558fd56b2b96a (diff)
gnu: Add python-torchfile.
* gnu/packages/machine-learning.scm (python-torchfile): New variable.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 52db4795b0..9530910530 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -3092,6 +3092,26 @@ Note: currently this package does not provide GPU support.")
and common image transformations for computer vision.")
(license license:bsd-3)))
+(define-public python-torchfile
+ (package
+ (name "python-torchfile")
+ (version "0.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "torchfile" version))
+ (sha256
+ (base32
+ "0vhklj6krl9r0kdynb4kcpwp8y1ihl2zw96byallay3k9c9zwgd5"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #false)) ;there are no tests
+ (propagated-inputs
+ (list python-numpy))
+ (home-page "https://github.com/bshillingford/python-torchfile")
+ (synopsis "Torch7 binary serialized file parser")
+ (description "This package enables you to deserialize Lua torch-serialized objects from
+Python.")
+ (license license:bsd-3)))
+
(define-public python-hmmlearn
(package
(name "python-hmmlearn")