summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2022-09-29 11:02:02 +0200
committerLudovic Courtès <ludo@gnu.org>2022-10-17 09:47:49 +0200
commiteecb288ca2a3c9c8c540370a63f7101ed155b32a (patch)
tree37de17b8b5ad711cc90c41e99734cac1dd9d7ae0 /gnu/packages/machine-learning.scm
parenta3e20f35f53ab0809d128a68694b5f94a000b6b7 (diff)
gnu: Add nerd-dictation.
* gnu/packages/machine-learning.scm (nerd-dictation): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 34b82aa101..f2c9b8dace 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -3602,3 +3602,37 @@ simple speech recognition.")
"from .vosk_cffi import ffi, lib")
(("_c\\.")
"lib.")))))))))
+
+(define-public nerd-dictation
+ (let* ((commit "53ab129a5ee0f8b5df284e8cf2229219b732c59e")
+ (revision "0"))
+ (package
+ (name "nerd-dictation")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ideasman42/nerd-dictation")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "184qijiva1h1x00dzicik0yzgh78pq2lqr5fkgicgp26mkarlyhc"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "package/python"))))))
+ (propagated-inputs (list python-vosk))
+ (inputs (list pulseaudio xdotool))
+ (home-page "https://github.com/ideasman42/nerd-dictation")
+ (synopsis "Offline speech-to-text for desktop Linux")
+ (description "\
+This package provides simple access speech to text for using in
+Linux without being tied to a desktop environment, using the @code{vosk-api}.
+The user configuration lets you manipulate text using Python string
+operations. It has zero overhead, as this relies on manual activation and
+there are no background processes. Dictation is accessed manually with
+@code{nerd-dictation begin} and @code{nerd-dictation end} commands.")
+ (license license:gpl3+))))