summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2023-04-27 17:14:47 -0400
committerLudovic Courtès <ludo@gnu.org>2023-05-24 15:04:01 +0200
commit6d0571215d661d21cac2150ca45906e77a79a5fb (patch)
treefe00313b959dcb409f8407a0dce4ea9104d25f25 /gnu/packages/mail.scm
parentb5a85e31dd6fa3ed2582c79b8906abdc48ddd793 (diff)
gnu: isync: Add patch to improve openssl-3 compatibility.
* gnu/packages/patches/isync-openssl3-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/mail.scm (isync): Use patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index b6968d13de..02e0da2ec8 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2233,7 +2233,10 @@ hashing scheme (such as scrypt) plug-in for @code{Dovecot}.")
(uri (string-append "mirror://sourceforge/isync/isync/"
version "/isync-" version ".tar.gz"))
(sha256 (base32
- "1zq0wwvmqsl9y71546dr0aygzn9gjjfiw19hlcq87s929y4p6ckw"))))
+ "1zq0wwvmqsl9y71546dr0aygzn9gjjfiw19hlcq87s929y4p6ckw"))
+ (patches
+ ;; Likely to be included in next version
+ (search-patches "isync-openssl3-fix.patch"))))
(build-system gnu-build-system)
(native-inputs
(list perl))