summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-08 09:45:56 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-08 16:00:17 +0200
commit19fed0491502bcd64cd51666449a4a384f42fef9 (patch)
treef1848873397a9711e24f55272c8b15319f58658a /gnu/packages/mail.scm
parent2dfb9bbf237aaa2a0a905484e3286f78eb6e9f72 (diff)
gnu: opensmtpd: Patch FHS assumptions.
This fixes the following failure... # smtpctl show message 9275c3fbeccbae93 execl: No such file or directory ...due to the absence of ‘/bin/cat’ on GuixSD. * gnu/packages/mail.scm (opensmtpd)[arguments]: Add ‘patch-FHS-file-names’ phase.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index a9add98d14..d04fc518c8 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2018,6 +2018,13 @@ transfer protocols.")
"--with-path-CAfile=/etc/ssl/certs/ca-certificates.crt")
#:phases
(modify-phases %standard-phases
+ ;; Fix some incorrectly hard-coded external tool file names.
+ (add-after 'unpack 'patch-FHS-file-names
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "smtpd/smtpctl.c"
+ (("/bin/cat") (which "cat"))
+ (("/bin/sh") (which "sh")))
+ #t))
;; OpenSMTPD provides a single utility smtpctl to control the daemon and
;; the local submission subsystem. To accomodate systems that require
;; historical interfaces such as sendmail, newaliases or makemap, the