summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2018-07-27 18:15:27 +0200
committerJelle Licht <jlicht@fsfe.org>2018-08-03 03:15:26 +0200
commitae7c1c3704187405a1c4e7c039bf70df9327e6a6 (patch)
tree2cef5f8e5d27c899432bc62a682058cc01af8612 /gnu/packages/mail.scm
parent5803f87284c228ca131d74a4259238e7685526ac (diff)
gnu: Add imapfilter.
* gnu/packages/mail.scm (imapfilter): New variable.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 3d7b0e4632..67f490d414 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2554,3 +2554,47 @@ and binaries. It supports offline reading, scoring and killfiles, yEnc, NZB,
PGP handling, multiple servers, and secure connections.")
;; License of the docs: fdl-1.1; Others: gpl2.
(license (list fdl1.1+ gpl2))))
+
+(define-public imapfilter
+ (package
+ (name "imapfilter")
+ (version "2.6.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/lefcha/imapfilter/archive/"
+ "v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1yslvwr3w5fnl06gfrp0lim8zdlasx3cvgd2fsqi0695xnb9bsms"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'fix-include-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((pcre (assoc-ref inputs "pcre")))
+ (substitute* "src/Makefile"
+ (("INCDIRS =")
+ (string-append "INCDIRS ="
+ "-I" pcre "/include")))
+ #t))))))
+ (native-inputs
+ `(("lua" ,lua)
+ ("pcre" ,pcre)
+ ("openssl" ,openssl)))
+ (home-page "https://github.com/lefcha/imapfilter")
+ (synopsis "IMAP mail filtering utility")
+ (description "IMAPFilter is a mail filtering utility. It connects
+to remote mail servers using IMAP, sends searching queries to the server and
+processes mailboxes based on the results. It can be used to delete, copy,
+move, flag, etc. messages residing in mailboxes at the same or different mail
+servers. The 4rev1 and 4 versions of IMAP are supported.")
+ (license license:expat)))