summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-07-25 11:47:51 +0000
committerLeo Famulari <leo@famulari.name>2016-07-26 19:43:54 -0400
commitae83dcf6ba9687b7ff123fdd4a81eb952b7b7801 (patch)
treedd3c70fa4f2295c636e3d2450cc6918429901c41 /gnu/packages/mail.scm
parentd3896fc4ce46e26f2ff7e633344fe38e044023f3 (diff)
gnu: gmime: Remove 'gpg' to 'gpg2' substitution.
* gnu/packages/mail.scm (gmime)[arguments]: Remove the substitution which previously changed 'gpg' to 'gpg2' in 'patch-paths-in-tests' phase. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 9214b73758..f7a7623cc4 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
+;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -240,14 +241,14 @@ operating systems.")
'unpack 'patch-paths-in-tests
(lambda _
;; The test programs run several programs using 'system' with
- ;; hard-coded paths. Here we patch them all. We also change "gpg"
- ;; to "gpg2". We use ISO-8859-1 here because test-iconv.c contains
+ ;; hard-coded paths. Here we patch them all.
+ ;; We use ISO-8859-1 here because test-iconv.c contains
;; raw byte sequences in several different encodings.
(with-fluids ((%default-port-encoding #f))
(substitute* (find-files "tests" "\\.c$")
(("(system *\\(\")(/[^ ]*)" all pre prog-path)
(let* ((base (basename prog-path))
- (prog (which (if (string=? base "gpg") "gpg2" base))))
+ (prog (which base)))
(string-append pre
(or prog (error "not found: " base))))))))))))
(home-page "http://spruce.sourceforge.net/gmime/")