summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorTroy Sankey <sankeytms@gmail.com>2016-08-07 13:27:18 -0400
committerAlex Kost <alezost@gmail.com>2016-08-11 18:12:41 +0300
commitcaa6fc89c76903ecc527d8853ccf791c749e5a40 (patch)
treea76c1387cab816540e99afcd1c7d5c5082ba37f6 /gnu/packages/mail.scm
parent4b6909bc03269c3e73863069678df88d62c742f8 (diff)
gnu: python2-notmuch: Update to 0.22.1.
* gnu/packages/mail.scm (python2-notmuch): Update to 0.22.1 by inheriting from 'python-notmuch'. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm33
1 files changed, 1 insertions, 32 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 990739e383..dcfc9790ba 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -553,38 +553,7 @@ and search library.")
(license gpl3+)))
(define-public python2-notmuch
- (package
- (name "python2-notmuch")
- (version "0.15.2")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://pypi.python.org/packages/source/n/notmuch/notmuch-"
- version
- ".tar.gz"))
- (sha256
- (base32
- "18g8701ibr153ngsz258kgcd42wqnbf9ifpqig1bijy6b0zx9xn5"))))
- (build-system python-build-system)
- (inputs `(("notmuch" ,notmuch)))
- (arguments
- `(#:python ,python-2
- #:phases (modify-phases %standard-phases
- (add-before
- 'build 'set-libnotmuch-file-name
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((notmuch (assoc-ref inputs "notmuch")))
- (substitute* "notmuch/globals.py"
- (("libnotmuch\\.so\\.[0-9]")
- (string-append notmuch "/lib/libnotmuch.so.4")))
- #t))))
- #:tests? #f)) ;no "test" target
- (home-page "http://notmuchmail.org/")
- (synopsis "Python bindings of the Notmuch mail indexing library")
- (description
- "This package provides Python bindings to use the Notmuch mail indexing
-and search library.")
- (license gpl3+)))
+ (package-with-python2 python-notmuch))
(define-public getmail
(package