summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-12-20 21:55:53 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-12-20 22:43:06 +0200
commitde75f0b1bfd2396a3eb17c0119bc5dbade66e134 (patch)
tree130148ca5501538caaeb1b5ee43fc1c468697421 /gnu/packages/mail.scm
parentabe5d2dc8d7c40553f723428344d071b6fb1ec45 (diff)
gnu: mailutils: Use 'modify-phases' syntax.
* gnu/packages/mail.scm (mailutils)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm74
1 files changed, 37 insertions, 37 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index fef913dca2..4ce7b1e996 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -113,43 +113,43 @@
"1dpylyg79avi7brpkcmzaq7bqqkz45flp0ws6f2c8b1gyz4hdnzm"))))
(build-system gnu-build-system)
(arguments
- '(;; TODO: Add `--with-sql'.
- #:phases (alist-cons-before
- 'build 'pre-build
- (lambda _
- ;; Use the right file name for `cat'.
- (substitute* "testsuite/lib/mailutils.exp"
- (("/bin/cat")
- (which "cat")))
-
- ;; Tests try to invoke 'maidag' such that it looks up the
- ;; 'root' user, which does not exist in the build
- ;; environment.
- (substitute* "maidag/tests/testsuite"
- (("root <") "nobody <")
- (("spool/root") "spool/nobody")
- (("root@localhost") "nobody@localhost"))
-
- ;; The 'pipeact.at' tests generate a shell script; make
- ;; sure it uses the right shell.
- (substitute* '("sieve/tests/testsuite"
- "mh/tests/testsuite")
- (("#! /bin/sh")
- (string-append "#!" (which "sh"))))
-
- (substitute* "mh/tests/testsuite"
- (("moreproc: /bin/cat")
- (string-append "moreproc: " (which "cat"))))
-
- ;; XXX: The comsatd tests rely on being able to open
- ;; /dev/tty, but that gives ENODEV in the build
- ;; environment. Thus, ignore test failures here.
- (substitute* "comsat/tests/Makefile.in"
- (("\\$\\(SHELL\\) \\$\\(TESTSUITE\\)" all)
- (string-append "-" all)))
-
- #t)
- %standard-phases)
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'pre-build
+ (lambda _
+ ;; Use the right file name for `cat'.
+ (substitute* "testsuite/lib/mailutils.exp"
+ (("/bin/cat")
+ (which "cat")))
+
+ ;; Tests try to invoke 'maidag' such that it looks up the
+ ;; 'root' user, which does not exist in the build
+ ;; environment.
+ (substitute* "maidag/tests/testsuite"
+ (("root <") "nobody <")
+ (("spool/root") "spool/nobody")
+ (("root@localhost") "nobody@localhost"))
+
+ ;; The 'pipeact.at' tests generate a shell script; make
+ ;; sure it uses the right shell.
+ (substitute* '("sieve/tests/testsuite"
+ "mh/tests/testsuite")
+ (("#! /bin/sh")
+ (string-append "#!" (which "sh"))))
+
+ (substitute* "mh/tests/testsuite"
+ (("moreproc: /bin/cat")
+ (string-append "moreproc: " (which "cat"))))
+
+ ;; XXX: The comsatd tests rely on being able to open
+ ;; /dev/tty, but that gives ENODEV in the build
+ ;; environment. Thus, ignore test failures here.
+ (substitute* "comsat/tests/Makefile.in"
+ (("\\$\\(SHELL\\) \\$\\(TESTSUITE\\)" all)
+ (string-append "-" all)))
+
+ #t)))
+ ;; TODO: Add `--with-sql'.
#:configure-flags '("--sysconfdir=/etc")
#:parallel-tests? #f))
(inputs