summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-01-26 22:14:38 +0100
committerLudovic Courtès <ludo@gnu.org>2023-01-26 23:22:34 +0100
commitc2b40b4b4c9e0227e47730ebe73a653b89d1e568 (patch)
tree20e72fea52b41f0a83c25e96e128b3d71995f099 /gnu/packages/make-bootstrap.scm
parentc6ec9c7af9814f84f293f62235eab9d0649751a7 (diff)
gnu: guile-static: Use 'gcc-ar' and 'gcc-ranlib'.
Fixes a regression introduced in 0e480ca7b60428a62fc4681d7aca6c7c067add42 whereby '%guile-static-3.0' would fail to build with "undefined reference" errors at link time. Fixes <https://issues.guix.gnu.org/61080>. Reported by Hilton Chain <hako@ultrarare.space>. * gnu/packages/make-bootstrap.scm (make-guile-static): Pass 'AR' and 'RANLIB' as #:configure-flags.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index a0999cb477..51b2cb3267 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012-2021, 2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Mark H Weaver <mhw@netris.org>
@@ -706,6 +706,14 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; doesn't try to link using libtool, and thus fails
;; because of a missing -ldl. Work around that.
`(list "LDFLAGS=-ldl" "--enable-mini-gmp"
+
+ ;; Guile does an LTO build by default, but in 3.0.9 it
+ ;; wrongfully picks 'ar' instead of 'gcc-ar', so work around
+ ;; it (see <https://issues.guix.gnu.org/61086>).
+ ,@(if (version-prefix? "3.0" (package-version guile))
+ '("AR=gcc-ar" "RANLIB=gcc-ranlib")
+ '())
+
,@(if (hurd-target?)
'("--disable-jit")
'())))