summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-03-27 12:29:39 +0200
committerLudovic Courtès <ludo@gnu.org>2023-03-30 12:44:21 +0200
commitca7b1e2fd71fe123e396179a2d3efbfb6eb2cc73 (patch)
tree5e1dc59d5ef9d24f5c3172e329ccc97bc7057d3f /gnu/packages/make-bootstrap.scm
parent83125dbc94aa1bb110d170d46ed70b8fdbd5f15e (diff)
gnu: guile-static: Switch to gexps.
* gnu/packages/make-bootstrap.scm (make-guile-static): Switch to gexps.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm68
1 files changed, 34 insertions, 34 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 2eed01ece8..6bafc5697c 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -613,44 +613,44 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(replace "libgc" libgc/static-libs)))
(arguments
(substitute-keyword-arguments (package-arguments guile)
- ((#:configure-flags flags '())
+ ((#:configure-flags flags #~'())
;; When `configure' checks for ltdl availability, it
;; doesn't try to link using libtool, and thus fails
;; because of a missing -ldl. Work around that.
- `(list "LDFLAGS=-ldl" "--enable-mini-gmp"
-
- ;; Guile does an LTO build by default, but in 3.0.9 it
- ;; wrongfully picks 'ar' instead of 'gcc-ar', so work around
- ;; it (see <https://issues.guix.gnu.org/61086>).
- ,@(if (version-prefix? "3.0" (package-version guile))
- '("AR=gcc-ar" "RANLIB=gcc-ranlib")
- '())
-
- ,@(if (hurd-target?)
- '("--disable-jit")
- '())))
+ #~(list "LDFLAGS=-ldl" "--enable-mini-gmp"
+
+ ;; Guile does an LTO build by default, but in 3.0.9 it
+ ;; wrongfully picks 'ar' instead of 'gcc-ar', so work around
+ ;; it (see <https://issues.guix.gnu.org/61086>).
+ #$@(if (version-prefix? "3.0" (package-version guile))
+ #~("AR=gcc-ar" "RANLIB=gcc-ranlib")
+ #~())
+
+ #$@(if (hurd-target?)
+ #~("--disable-jit")
+ #~())))
((#:phases phases '%standard-phases)
- `(modify-phases ,phases
-
- ;; Do not record the absolute file name of 'sh' in
- ;; (ice-9 popen). This makes 'open-pipe' unusable in
- ;; a build chroot ('open-pipe*' is fine) but avoids
- ;; keeping a reference to Bash.
- (delete 'pre-configure)
-
- (add-before 'configure 'static-guile
- (lambda _
- (substitute* "libguile/Makefile.in"
- ;; Create a statically-linked `guile'
- ;; executable.
- (("^guile_LDFLAGS =")
- "guile_LDFLAGS = -all-static")
-
- ;; Add `-ldl' *after* libguile-2.0.la.
- (("^guile_LDADD =(.*)$" _ ldadd)
- (string-append "guile_LDADD = "
- (string-trim-right ldadd)
- " -ldl\n")))))))
+ #~(modify-phases #$phases
+
+ ;; Do not record the absolute file name of 'sh' in
+ ;; (ice-9 popen). This makes 'open-pipe' unusable in
+ ;; a build chroot ('open-pipe*' is fine) but avoids
+ ;; keeping a reference to Bash.
+ (delete 'pre-configure)
+
+ (add-before 'configure 'static-guile
+ (lambda _
+ (substitute* "libguile/Makefile.in"
+ ;; Create a statically-linked `guile'
+ ;; executable.
+ (("^guile_LDFLAGS =")
+ "guile_LDFLAGS = -all-static")
+
+ ;; Add `-ldl' *after* libguile-2.0.la.
+ (("^guile_LDADD =(.*)$" _ ldadd)
+ (string-append "guile_LDADD = "
+ (string-trim-right ldadd)
+ " -ldl\n")))))))
((#:tests? _ #f)
;; There are uses of `dynamic-link' in
;; {foreign,coverage}.test that don't fly here.