summaryrefslogtreecommitdiff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorLilah Tascheter <lilah@lunabee.space>2022-08-27 18:37:54 -0500
committerLudovic Courtès <ludo@gnu.org>2022-09-08 16:22:21 +0200
commit4ace4692c09ec65a5be7968b44ebd6e42a9c3b32 (patch)
tree00af1eb435ebc8d7e73a83ab53e476971930c89a /gnu/packages/man.scm
parent97cccd343363530c8577daa43deb9ca7528f0271 (diff)
gnu: Add man-pages-posix.
* gnu/packages/man.scm (man-pages-posix): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 1c1d82758b..f1e9a7aa78 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -302,6 +302,39 @@ Linux kernel and C library interfaces employed by user-space programs.")
;; Each man page has its own license; some are GPLv2+, some are MIT/X11.
(license license:gpl2+)))
+(define-public man-pages-posix
+ (package
+ (name "man-pages-posix")
+ (version "2013-a")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kernel.org/linux/docs/man-pages/"
+ "man-pages-posix/man-pages-posix-" version
+ ".tar.xz"))
+ (sha256
+ (base32 "0258j05zdrxpgdj8nndbyi7bvrs8fxdksb0xbfrylzgzfmf3lqqr"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ ;; The compress-documentation phase doesn't pick up on our manpages as
+ ;; its regex doesn't support trailing letters, so manually compress.
+ #:make-flags ,#~(list (string-append "prefix=" #$output) "gz")
+ #:license-file-regexp "POSIX-COPYRIGHT"
+ #:phases (modify-phases %standard-phases (delete 'configure))))
+ (home-page "https://www.kernel.org/doc/man-pages/")
+ (synopsis "Man pages from the POSIX.1-2013 standard")
+ (description
+ "This package provides excerpts from the POSIX.1-2008 and TC1 standards
+(collectively, POSIX.1-2013) in manual page form. While the Linux man-pages
+project documents the system as it exists on Linux- and glibc-based systems,
+this package documents the portable software API as nominally implemented by
+many Unix-likes.")
+ (license (license:fsdg-compatible "file://POSIX-COPYRIGHT"
+ "Redistribution of this material is permitted so long as this
+notice and the corresponding notices within each POSIX manual page are retained
+on any distribution, and the nroff source is included."))))
+
(define-public help2man
;; TODO: Manual pages for languages not available from the implicit
;; input "locales" contain the original (English) text.