summaryrefslogtreecommitdiff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-30 13:39:54 +0200
committerMarius Bakke <marius@gnu.org>2022-06-30 23:26:17 +0200
commit79beb855991c907159bd7fa16feb47e1bc09ac9b (patch)
tree209e7f19496371dfdf49bd3a020518ac3cdb6267 /gnu/packages/man.scm
parentddff3be27e995f9d1e3e5fa545da4961d616051c (diff)
gnu: help2man: Remove input labels.
* gnu/packages/man.scm (help2man)[arguments]: Rewrite as G-expression. [inputs, native-inputs]: Remove labels.
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm50
1 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 98a285593e..89db08cab8 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2015, 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2019, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
@@ -310,33 +310,33 @@ Linux kernel and C library interfaces employed by user-space programs.")
(version "1.49.2")
(source
(origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/help2man/help2man-"
- version ".tar.xz"))
- (sha256
- (base32
- "0dnxx96lbcb8ab8yrdkqll14cl5n0bch8qpd9qj3c2ky78hhwbly"))))
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/help2man/help2man-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0dnxx96lbcb8ab8yrdkqll14cl5n0bch8qpd9qj3c2ky78hhwbly"))))
(build-system gnu-build-system)
- (arguments `(;; There's no `check' target.
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-help2man-with-perl-gettext
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((lib (assoc-ref inputs "perl-gettext"))
- (fmt "use lib '~a/lib/perl5/site_perl';~%~a"))
- (substitute* "help2man.PL"
- (("^use Locale::gettext.*$" load)
- (format #f fmt lib load))))
- #t)))))
+ (arguments
+ (list
+ #:tests? #f ;no `check' target
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-help2man-with-perl-gettext
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((lib #$(this-package-input "perl-gettext"))
+ (fmt "use lib '~a/lib/perl5/site_perl';~%~a"))
+ (substitute* "help2man.PL"
+ (("^use Locale::gettext.*$" load)
+ (format #f fmt lib load)))))))))
(inputs
- `(("perl" ,perl)
- ,@(if (%current-target-system)
- '()
- `(("perl-gettext" ,perl-gettext)))))
+ (append
+ (list perl)
+ (if (%current-target-system)
+ '()
+ (list perl-gettext))))
(native-inputs
- `(("perl" ,perl)
- ("gettext" ,gettext-minimal)))
+ (list perl gettext-minimal))
(home-page "https://www.gnu.org/software/help2man/")
(synopsis "Automatically generate man pages from program --help")
(description