summaryrefslogtreecommitdiff
path: root/gnu/packages/markup.scm
diff options
context:
space:
mode:
authorHendursaga <hendursaga@aol.com>2023-09-22 11:22:28 -0400
committerChristopher Baines <mail@cbaines.net>2023-09-27 12:08:02 +0100
commite13a525d25b26bd7c9c8bb916df66eff261ccad5 (patch)
tree9058d3fd1979f4ecb138aaf02e9cec0a22adc284 /gnu/packages/markup.scm
parent105113f241f5814759d4ff4c7b95376f8b8d450d (diff)
gnu: cmark: Update to 0.30.3.
* gnu/packages/markup.scm (cmark): Update to 0.30.3. [source]: Update URL. [description]: Improve description. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/markup.scm')
-rw-r--r--gnu/packages/markup.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 6cb54d0d8f..ad2d74f742 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -332,28 +332,28 @@ convert HTML to Markdown.")
(define-public cmark
(package
(name "cmark")
- (version "0.30.2")
+ (version "0.30.3")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jgm/cmark")
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/commonmark/cmark")
(commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1426snw3mq8qmpdxznkhsyy75xd9v9nwlc7sph08qpdz8xnp4hr2"))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07d30s5v893nb1m7qbam5c3x9b3d84m80kzlj7fmkwhgjrlz7d7z"))))
(build-system cmake-build-system)
(arguments
'(#:test-target "test"))
(native-inputs (list python))
(synopsis "CommonMark Markdown reference implementation")
- (description "CommonMark is a strongly defined, highly compatible
-specification of Markdown. cmark is the C reference implementation of
-CommonMark. It provides @code{libcmark} shared library for parsing
-CommonMark to an abstract syntax tree (@dfn{AST}) and rendering the document
-as HTML, groff man, LaTeX, CommonMark, or an XML representation of the
-AST. The package also provides the command-line program @command{cmark}
-for parsing and rendering CommonMark.")
+ (description
+ "CommonMark is a strongly defined, highly compatible specification of
+Markdown. @code{cmark} is the C reference implementation of CommonMark. It
+provides the @code{libcmark} shared library for parsing CommonMark to an
+abstract syntax tree (@dfn{AST}) and rendering the document as HTML, groff man,
+LaTeX, CommonMark, or an XML representation of the AST. It also provides the
+command-line program @command{cmark} for parsing and rendering CommonMark.")
(home-page "https://commonmark.org")
;; cmark is distributed with a BSD-2 license, but some components are Expat
;; licensed. The CommonMark specification is Creative Commons CC-BY-SA 4.0