summaryrefslogtreecommitdiff
path: root/gnu/packages/markup.scm
diff options
context:
space:
mode:
authorSkylar Chan <schan12@umd.edu>2023-11-11 08:29:21 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-11-11 08:36:31 +0800
commit2a638e0bbc07cc1cce25d66229ca185eb197f589 (patch)
treea633c1412825adb4f60e6ee1f9334372c6f741c1 /gnu/packages/markup.scm
parentf39cac1d0ccc522ae98e27301910eedd2ae9ad18 (diff)
gnu: lowdown: Update to 1.1.0.
* gnu/packages/markup.scm (lowdown): Update to 1.1.0. [source]: Use upstream tarball and switch to url-fetch. [arguments]<phases>: Install with "make install install_libs". Change-Id: I2268c587be2fddb43fdf9ae957b6e5344e5f2984 Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/markup.scm')
-rw-r--r--gnu/packages/markup.scm66
1 files changed, 33 insertions, 33 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 6ee7bebf57..595b08fa20 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -125,39 +125,39 @@ convert it to structurally valid XHTML (or HTML).")
"See License.text in the distribution."))))
(define-public lowdown
- (let ((commit "1de10c1d71bfb4348ae0beaec8b1547d5e114969")
- (revision "1"))
- (package
- (name "lowdown")
- (version (git-version "0.10.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kristapsdz/lowdown")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1wh07nkiihvp1m79sj4qlnqklnn0rfp3hwls8sqcp0bfd96wpa1h"))))
- (build-system gnu-build-system)
- (arguments
- (list
- #:test-target "regress"
- #:phases
- #~(modify-phases %standard-phases
- (replace 'configure
- (lambda _
- (invoke "./configure"
- (string-append "PREFIX=" #$output)
- (string-append "MANDIR=" #$output "/share/man")))))
- #:make-flags #~(list "CFLAGS=-fPIC")))
- (native-inputs
- (list which))
- (home-page "https://kristaps.bsd.lv/lowdown/")
- (synopsis "Simple Markdown translator")
- (description "Lowdown is a Markdown translator producing HTML5,
-roff documents in the ms and man formats, LaTeX, gemini, and terminal output.")
- (license license:isc))))
+ (package
+ (name "lowdown")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://kristaps.bsd.lv/lowdown/snapshots/lowdown-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0y88gffrg1zrin0y53j4gbkmpia0r8p0kyklj501wavkqi83j7pk"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:test-target "regress"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "./configure"
+ (string-append "PREFIX=" #$output)
+ (string-append "MANDIR=" #$output "/share/man"))))
+ (replace 'install
+ (lambda _
+ (invoke "make" "install" "install_libs"))))
+ #:make-flags #~(list "CFLAGS=-fPIC")))
+ (native-inputs
+ (list which))
+ (home-page "https://kristaps.bsd.lv/lowdown/")
+ (synopsis "Simple Markdown translator")
+ (description "Lowdown is a Markdown translator producing HTML5, roff
+documents in the ms and man formats, LaTeX, gemini, and terminal output.")
+ (license license:isc)))
(define-public discount
(package