summaryrefslogtreecommitdiff
path: root/gnu/packages/mastodon.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-06-05 10:23:45 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-15 14:25:29 +0300
commita0d2ecde943bd1854ddbb7c0cad35a1fc64dc5ab (patch)
tree77f44035ebf5d7b3bffeb4de935f6af2782fa3ae /gnu/packages/mastodon.scm
parentef026e68fe58ed3be216c76f7c5f008893ed3095 (diff)
gnu: tootle: Deprecate in favor of tuba.
* gnu/packages/mastodon.scm (tootle): Deprecate for tuba. * gnu/packages/patches/tootle-glib-object-renaming.patch, gnu/packages/patches/tootle-reason-phrase.patch: Remove files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/mastodon.scm')
-rw-r--r--gnu/packages/mastodon.scm63
1 files changed, 1 insertions, 62 deletions
diff --git a/gnu/packages/mastodon.scm b/gnu/packages/mastodon.scm
index c1237b2a55..44f8664997 100644
--- a/gnu/packages/mastodon.scm
+++ b/gnu/packages/mastodon.scm
@@ -144,68 +144,7 @@ seamlessly with your desktop environment.")
(license license:gpl3)))
(define-public tootle
- (package
- (name "tootle")
- (version "1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/bleakgrey/tootle")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1nm57239mhdq462an6bnhdlijpijxmjs9mqbyirwxwa048d3n4rm"))
- (patches
- (search-patches
- ;; https://github.com/bleakgrey/tootle/pull/339
- "tootle-glib-object-naming.patch"
- ;; https://github.com/bleakgrey/tootle/pull/322
- "tootle-reason-phrase.patch"))))
- (build-system meson-build-system)
- (arguments
- `(#:glib-or-gtk? #t
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-gtk-update-icon-cache
- ;; Don't create 'icon-theme.cache'.
- (lambda _
- (substitute* "meson/post_install.py"
- (("gtk-update-icon-cache") "true"))))
- (add-after 'unpack 'patch-source
- (lambda _
- (substitute* "src/Dialogs/NewAccount.vala"
- (("xdg-mime") (which "xdg-mime")))
- ;; Patch for building on glib < 2.64
- (substitute* "src/Build.vala"
- (("(os_name = ).*" _ first) (string-append first "\"GNU\";\n"))
- (("(os_ver = ).*" _ first) (string-append first "\"Guix\";\n"))
- (("GLib.Environment.get_os_info.*") "\"unknown\";\n"))))
- (add-after 'install 'symlink-package
- (lambda* (#:key outputs #:allow-other-keys)
- (symlink "com.github.bleakgrey.tootle"
- (string-append (assoc-ref outputs "out")
- "/bin/tootle")))))))
- (native-inputs
- (list gettext-minimal
- `(,glib "bin") ; for glib-compile-resources
- gsettings-desktop-schemas pkg-config))
- (inputs
- (list glib-networking
- gtk+
- json-glib
- libgee
- libhandy
- libsoup-minimal-2
- vala
- xdg-utils))
- (home-page "https://github.com/bleakgrey/tootle")
- (synopsis "GTK3 client for Mastodon")
- (description "Tootle is a GTK client for Mastodon. It provides a clean,
-native interface that allows you to integrate Mastodon's social experience
-seamlessly with your desktop environment.")
- (license license:gpl3+)))
+ (deprecated-package "tootle" tuba))
(define-public python-mastodon-py
(package