summaryrefslogtreecommitdiff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-03-28 13:38:34 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-21 20:26:42 -0500
commitc20736562de91ec994e90678fa3ea5083abb114e (patch)
treee250cf2bc2a710329a2fb1715213e4120accaf86 /gnu/packages/mate.scm
parent552ebc47afaa3b3ffd0086cf47c3e6ad475effc6 (diff)
gnu: Use 'gtk-doc/stable' in native-inputs instead of 'gtk-doc'.
Commit 9dea1618755891526f708aa335b4136c1302d16e only replaced 'gtk-doc' with 'gtk-doc/stable' in the native-inputs of some packages, but we may as well do this for all packages. * gnu/packages/admin.scm (thermald) [native-inputs]: Replace 'gtk-doc' with 'gtk-doc/stable'. * gnu/packages/glib.scm (glib-with-documentation): Likewise. * gnu/packages/mate.scm (mate-desktop, atril, caja-extensions) (mate-utils, eom, engrampa, pluma, mate-polkit) [native-inputs]: Likewise. * gnu/packages/messaging.scm (libgnt, loudmouth) [native-inputs]: Likewise. * gnu/packages/music.scm (denemo, gsequencer) [native-inputs]: Likewise. * gnu/packages/photo.scm (entangle) [native-inputs]: Likewise. * gnu/packages/security-token.scm (libu2f-host, libu2f-server) [native-inputs]: Likewise. * gnu/packages/wm.scm (keybinder, keybinder-3.0) [native-inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I6c647ff1394e0a48bef0e6fb1ae43533673f1d79
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 5a6c6b5b64..6a1fd0d6f6 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -238,7 +239,7 @@ themes for both gtk+-2 and gtk+-3.")
`(,glib "bin")
gobject-introspection
yelp-tools
- gtk-doc))
+ gtk-doc/stable))
(inputs
(list gtk+ libxrandr iso-codes startup-notification))
(propagated-inputs
@@ -733,7 +734,7 @@ infamous 'Wanda the Fish'.")
("yelp-tools" ,yelp-tools)
("glib:bin" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
- ("gtk-doc" ,gtk-doc)
+ ("gtk-doc" ,gtk-doc/stable)
("texlive-bin" ,texlive-bin) ;synctex
("xmllint" ,libxml2)
("zlib" ,zlib)))
@@ -869,7 +870,7 @@ icons on the MATE desktop. It works on local and remote file systems.")
("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
- ("gtk-doc" ,gtk-doc)
+ ("gtk-doc" ,gtk-doc/stable)
("libxml2" ,libxml2)
("pkg-config" ,pkg-config)))
(inputs
@@ -1228,7 +1229,7 @@ can be used as backgrounds in the MATE Desktop environment.")
(build-system glib-or-gtk-build-system)
(native-inputs
(list gettext-minimal
- gtk-doc
+ gtk-doc/stable
intltool
libice
libsm
@@ -1280,7 +1281,7 @@ can be used as backgrounds in the MATE Desktop environment.")
(build-system glib-or-gtk-build-system)
(native-inputs
(list gettext-minimal
- gtk-doc
+ gtk-doc/stable
gobject-introspection
intltool
pkg-config
@@ -1344,7 +1345,7 @@ can be used as backgrounds in the MATE Desktop environment.")
#t)))))
(native-inputs
`(("gettext" ,gettext-minimal)
- ("gtk-doc" ,gtk-doc)
+ ("gtk-doc" ,gtk-doc/stable)
("intltool" ,intltool)
("pkg-config" ,pkg-config)
("yelp-tools" ,yelp-tools)))
@@ -1384,7 +1385,7 @@ can be used as backgrounds in the MATE Desktop environment.")
#:tests? #f))
(native-inputs
`(("gettext" ,gettext-minimal)
- ("gtk-doc" ,gtk-doc)
+ ("gtk-doc" ,gtk-doc/stable)
("gobject-introspection" ,gobject-introspection)
("intltool" ,intltool)
("libtool" ,libtool)
@@ -1464,7 +1465,7 @@ MATE Desktop to monitor your system resources and usage.")
"0mq3a9ab4fxpkah6c5p7a0zsy8cixfc5j9030k204cy5vysv1dzm"))))
(build-system glib-or-gtk-build-system)
(native-inputs
- (list gettext-minimal gtk-doc intltool libtool pkg-config))
+ (list gettext-minimal gtk-doc/stable intltool libtool pkg-config))
(inputs
(list accountsservice
glib