summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2023-02-01 22:39:56 -0800
committerGuillaume Le Vaillant <glv@posteo.net>2023-02-08 17:09:07 +0100
commit417269da945b5d203f6ea87cfc86fdd7397d167b (patch)
tree228845c1bfd31f3f4bd5fe0ee0de715c0efc5630 /gnu/packages/maths.scm
parentd6e2b467b88d0f663a941b796b2933ed009fca3f (diff)
gnu: wxmaxima: Update to 22.12.0.
* gnu/packages/maths.scm (wxmaxima): Update to 22.12.0. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm57
1 files changed, 28 insertions, 29 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4640237968..321a90e651 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4551,28 +4551,27 @@ point numbers.")
(define-public wxmaxima
(package
(name "wxmaxima")
- (version "22.05.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/wxMaxima-developers/wxmaxima")
- (commit (string-append "Version-" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1va56v9dys97yln4m1z3fz3k90lpy8i3kvcq0v1cbg36689aghm5"))))
+ (version "22.12.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wxMaxima-developers/wxmaxima")
+ (commit (string-append "Version-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12bjadmy2mf7d8v4iszmzckahfcwjzaba8wpbigksh4brvhb4gj5"))))
(build-system cmake-build-system)
- (native-inputs
- `(("gettext" ,gettext-minimal)))
- (inputs
- (list wxwidgets
- maxima
- ;; Runtime support.
- adwaita-icon-theme
- gtk+
- shared-mime-info))
+ (native-inputs (list gettext-minimal))
+ (inputs (list bash-minimal
+ wxwidgets
+ maxima
+ ;; Runtime support.
+ adwaita-icon-theme
+ gtk+
+ shared-mime-info))
(arguments
- `(#:tests? #f ; tests fail non-deterministically
+ `(#:tests? #f ; tests fail non-deterministically
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-doc-path
@@ -4581,8 +4580,8 @@ point numbers.")
;; documentation. Only licensing information is placed there by
;; Guix.
(substitute* "src/Dirstructure.cpp"
- (("/doc/wxmaxima-\\%s") "/doc/wxmaxima"))
- #t))
+ (("/doc/wxmaxima-\\%s")
+ "/doc/wxmaxima"))))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
(wrap-program (string-append (assoc-ref outputs "out")
@@ -4595,15 +4594,15 @@ point numbers.")
(,(string-append (assoc-ref inputs "gtk+")
"/share/glib-2.0/schemas")))
`("XDG_DATA_DIRS" ":" prefix
- (;; Needed by gdk-pixbuf to know supported icon formats.
- ,(string-append
- (assoc-ref inputs "shared-mime-info") "/share")
+ ( ;; Needed by gdk-pixbuf to know supported icon formats.
+ ,(string-append (assoc-ref inputs "shared-mime-info")
+ "/share")
;; The default icon theme of GTK+.
- ,(string-append
- (assoc-ref inputs "adwaita-icon-theme") "/share"))))
- #t)))))
+ ,(string-append (assoc-ref inputs "adwaita-icon-theme")
+ "/share")))))))))
(home-page "https://wxmaxima-developers.github.io/wxmaxima/")
- (synopsis "Graphical user interface for the Maxima computer algebra system")
+ (synopsis
+ "Graphical user interface for the Maxima computer algebra system")
(description
"wxMaxima is a graphical user interface for the Maxima computer algebra
system. It eases the use of Maxima by making most of its commands available