summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-30 11:54:32 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-30 11:54:32 +0200
commit7d134b57b79188f8c878625d4e09f9bd6181e8c0 (patch)
treefae437f88c666ccf877518b53ea3707f4bc04ec3 /gnu/packages/maths.scm
parentb18b2d13488f2a92331ccad2dc8cbb54ee15582f (diff)
parentee5de9cdf2e9d914638fcac8b5f25bdddfb73dfc (diff)
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm62
1 files changed, 45 insertions, 17 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 45ca49e04f..e060183a74 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1742,27 +1742,52 @@ System (Grid, Point and Swath).")
(define-public hdf-eos5
(package
(name "hdf-eos5")
- (version "1.15")
- (source (origin
- (method url-fetch)
- (uri (string-append "ftp://edhs1.gsfc.nasa.gov\
-/edhs/hdfeos5/latest_release/HDF-EOS5." version ".tar.Z"))
- (sha256
- (base32
- "1p83333nzzy8rn5chxlm0hrkjjnhh2w1ji8ac0f9q4xzg838i58i"))
- (patches (search-patches "hdf-eos5-build-shared.patch"
- "hdf-eos5-remove-gctp.patch"
- "hdf-eos5-fix-szip.patch"
- "hdf-eos5-fortrantests.patch"))))
+ (version "2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://git.earthdata.nasa.gov/projects/DAS/repos/hdfeos5/raw/"
+ "hdf-eos5-" version "-src.tar.gz?at=refs/heads/HDFEOS5_" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0by82zznms00b0d5v4iv8a7jff6xm9hzswsx4mfzw2gyy1q4ghyp"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ (for-each delete-file (find-files "." "Makefile\\.in$"))
+ (for-each delete-file (find-files "m4" "^l.*\\.m4$"))
+ (delete-file "configure")
+ (delete-file "aclocal.m4")))))
(native-inputs
- (list gfortran))
+ (list autoconf automake gfortran libtool))
(build-system gnu-build-system)
(inputs
- (list hdf5-1.8 zlib gctp))
+ (list hdf5-1.14 zlib gctp))
(arguments
- `(#:configure-flags '("--enable-install-include" "--enable-shared"
+ (list
+ #:configure-flags ''("--enable-install-include" "--enable-shared"
"CC=h5cc -Df2cFortran" "LIBS=-lgctp")
- #:parallel-tests? #f))
+ #:parallel-tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-single_module-flag
+ (lambda _
+ (substitute* "src/Makefile.am"
+ ((",-single_module") ""))))
+ (add-after 'unpack 'fix-parallel-tests
+ (lambda _
+ (substitute* (find-files "testdrivers" "\\.c$")
+ (("#include <HE5_HdfEosDef.h>" orig)
+ (string-append "#include <HE5_config.h>\n" orig)))
+ ;; pthread is already linked.
+ (substitute* "testdrivers/threads/Makefile.am"
+ (("(LDADD=\\$\\(LIBHDFEOS5\\) \\$\\(LIBGCTP\\)) pthread" _ rest)
+ rest))
+ ;; This file is missing in the testdrivers/threads directory.
+ (copy-file "testdrivers/point/simple.txt"
+ "testdrivers/threads/simple.txt"))))))
(synopsis "HDF5-based data format for NASA's Earth Observing System")
(description
"HDF-EOS5 is a software library built on HDF5 to support the construction
@@ -4636,7 +4661,10 @@ parts of it.")
(arguments
(substitute-keyword-arguments (package-arguments openblas)
((#:make-flags flags #~'())
- #~(append (list "INTERFACE64=1" "LIBNAMESUFFIX=ilp64")
+ ;; These should be '64' but julia hardcodes '64_'.
+ #~(append (list "INTERFACE64=1"
+ "SYMBOLSUFFIX=64_"
+ "LIBPREFIX=libopenblas64_")
#$flags))))
(synopsis "Optimized BLAS library based on GotoBLAS (ILP64 version)")
(license license:bsd-3)))