summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2023-10-05 21:34:48 +0000
committerLudovic Courtès <ludo@gnu.org>2023-10-06 12:26:45 +0200
commit97edef50f420b719a3c8d250096c64d5e04646b9 (patch)
treebe9141cf32ac481eceba1b278aee16f10a4d784e /gnu/packages/maths.scm
parent913e2dd61f175ee8782c608b8c2339e8ae6b24bd (diff)
gnu: Add suitesparse-camd.
* gnu/packages/maths.scm (suitesparse-camd): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1b1a39688b..e2c0492ccb 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5201,6 +5201,51 @@ to Cholesky factorization (or for LU factorization with diagonal pivoting).")
matrix into block upper triangular form.")
(license license:lgpl2.1+)))
+(define-public suitesparse-camd
+ (package
+ (name "suitesparse-camd")
+ (version "3.2.0")
+ (source suitesparse-source)
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "CAMD")))
+ (add-after 'chdir 'set-cmake-module-path
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("set.*CMAKE_MODULE_PATH.*")
+ (string-append "set(CMAKE_MODULE_PATH "
+ #$suitesparse-config "/lib/cmake/SuiteSparse)\n"
+ "set(DUMMY\n")))))
+ (add-after 'build 'build-doc
+ (lambda _
+ (with-directory-excursion "../CAMD/Doc"
+ (invoke "make"))))
+ (add-after 'install 'install-doc
+ (lambda _
+ (install-file "../CAMD/Doc/CAMD_UserGuide.pdf"
+ (string-append #$output "/share/doc/"
+ #$name "-" #$version))))
+ (replace 'install-license-files
+ (lambda _
+ (install-file "../CAMD/Doc/License.txt"
+ (string-append #$output "/share/doc/"
+ #$name "-" #$version)))))))
+ (inputs (list suitesparse-config))
+ (native-inputs (list (texlive-updmap.cfg '())))
+ (home-page "https://people.engr.tamu.edu/davis/suitesparse.html")
+ (synopsis "Sparse matrix ordering for Cholesky factorization with constraints")
+ (description "CAMD is a set of routines for ordering a sparse matrix prior
+to Cholesky factorization (or for LU factorization with diagonal pivoting).
+It is a variant of AMD which has the the option to apply constraints to the
+ordering.")
+ (license license:bsd-3)))
+
(define-public suitesparse
(package
(name "suitesparse")