summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2023-10-05 21:34:59 +0000
committerLudovic Courtès <ludo@gnu.org>2023-10-06 12:26:46 +0200
commit9dde72a23cf628ec0663567cb98846771a0d4a04 (patch)
tree7cbb3fbc58754694e1c4cd7ff3597005d938c701 /gnu/packages/maths.scm
parente8903490672d3a9e64fab42c40644ffb802ae6d1 (diff)
gnu: Add suitesparse-rbio.
* gnu/packages/maths.scm (suitesparse-rbio): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 988bf28ac2..2cb1f01358 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5684,6 +5684,44 @@ LDL' factorization of sparse, symmetric matrices. Its focus lies on concise
code.")
(license license:lgpl2.1+)))
+(define-public suitesparse-rbio
+ (package
+ (name "suitesparse-rbio")
+ (version "4.2.0")
+ (source suitesparse-source)
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "RBio")))
+ (add-after 'chdir 'set-cmake-module-path
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("set.*CMAKE_MODULE_PATH.*")
+ (string-append
+ "set(CMAKE_MODULE_PATH "
+ (string-join
+ (map (lambda (path)
+ (string-append path "/lib/cmake/SuiteSparse"))
+ (list #$suitesparse-config)))
+ ")\nset(DUMMY\n")))))
+ (replace 'install-license-files
+ (lambda _
+ (let ((out (string-append #$output
+ "/share/doc/" #$name "-" #$version)))
+ (install-file "../RBio/Doc/License.txt" out)
+ (install-file "../RBio/Doc/gpl.txt" out)))))))
+ (inputs (list suitesparse-config))
+ (home-page "https://people.engr.tamu.edu/davis/suitesparse.html")
+ (synopsis "Library for the Rutherford/Boeing sparse matrix format")
+ (description "This package provides the C library of RBio. It can be used
+for reading and writing sparse matrices in the Rutherford/Boeing format.")
+ (license license:gpl2+)))
+
(define-public suitesparse
(package
(name "suitesparse")