summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-06-07 09:30:52 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-06-07 09:30:52 +0300
commita6e21911bf0dbc3c595d510729a012845d108aa9 (patch)
tree199e503ab2f683fec05747e8b9012301dd5acb8b /gnu/packages/maths.scm
parentf8b1e50f30eb20b1ce19ba01f4ffd78ca3590d0f (diff)
gnu: hdf4: Add support for riscv64-linux.
* gnu/packages/maths.scm (hdf4)[arguments]: Rename custom phase 'add-more-aarch64-support to 'add-more-architecture-support and add support for riscv64-linux. * gnu/packages/patches/hdf4-architectures.patch: Refresh from upstream.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4e34124469..4df535f0cb 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1314,13 +1314,12 @@ computations.")
#:phases
(modify-phases %standard-phases
;; This is inspired by two of Debian's patches.
- (add-before 'configure 'add-more-aarch64-support
+ (add-before 'configure 'add-more-architecture-support
(lambda _
(substitute* '("mfhdf/ncgen/ncgen.l"
"mfhdf/ncgen/ncgenyy.c"
"mfhdf/libsrc/netcdf.h.in")
- (("AIX5L64") "__aarch64__"))
- #t))
+ (("AIX5L64") "__aarch64__ || ( __riscv && __riscv_xlen == 64)"))))
(add-before 'configure 'patchbuild
(lambda _
(substitute*