summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:01 +0200
commitd6cb55b395cb2e613a26c1acceee3c8623ee5baf (patch)
treedee5b3db8bff375fff0da9eb52c1b50c38744f6d /gnu/packages/maths.scm
parent1cf84fb13bae42554f0d37cacac0ad9a9d74cedd (diff)
gnu: vc: Update to 1.4.3.
* gnu/packages/maths.scm (vc): Update to 1.4.3. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm39
1 files changed, 19 insertions, 20 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 8bfcd3c4db..12d802268e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5932,14 +5932,14 @@ supports compressed MAT files, as well as newer (version 7.3) MAT files.")
(define-public vc
(package
(name "vc")
- (version "1.4.2")
+ (version "1.4.3")
(source
- (origin (method url-fetch)
- (uri (string-append "https://github.com/VcDevel/Vc/releases/"
- "download/" version "/Vc-" version ".tar.gz"))
- (sha256
- (base32
- "0lirdqzcxys9walz04bllsphydynk7973aimd5k1h1qbwi8z3lsh"))))
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/VcDevel/Vc/releases/"
+ "download/" version "/Vc-" version ".tar.gz"))
+ (sha256
+ (base32 "0zq37r8yisd4dwlb024l10wk2yq9kisa4xm79ia1ggrz7w2s13lq"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
@@ -5953,24 +5953,23 @@ supports compressed MAT files, as well as newer (version 7.3) MAT files.")
(lambda* (#:key inputs native-inputs #:allow-other-keys)
(let ((testdata (assoc-ref (or native-inputs inputs)
"testdata")))
- (copy-recursively testdata "tests/testdata")
- #t))))))
+ (copy-recursively testdata "tests/testdata")))))))
(native-inputs
`(("virtest" ,virtest)
;; This is a submodule in the git project, but not part of the
;; released sources. See the git branch for the commit to take.
- ("testdata" ,(let ((commit "9ada1f34d6a41f1b5553d6223f277eae72c039d3"))
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/VcDevel/vc-testdata")
- (commit "9ada1f34d6a41f1b5553d6223f277eae72c039d3")))
- (file-name (git-file-name "vc-testdata"
- (string-take commit 7)))
- (sha256
- (base32
- "1hkhqib03qlcq412ym2dciynfxcdr2ygqhnplz4l1vissr1wnqn2")))))))
+ ("testdata"
+ ,(let ((commit "9ada1f34d6a41f1b5553d6223f277eae72c039d3"))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/VcDevel/vc-testdata")
+ (commit "9ada1f34d6a41f1b5553d6223f277eae72c039d3")))
+ (file-name (git-file-name "vc-testdata" (string-take commit 7)))
+ (sha256
+ (base32
+ "1hkhqib03qlcq412ym2dciynfxcdr2ygqhnplz4l1vissr1wnqn2")))))))
(synopsis "SIMD vector classes for C++")
(description "Vc provides portable, zero-overhead C++ types for explicitly
data-parallel programming. It is a library designed to ease explicit