summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2023-09-25 21:27:18 +0000
committerChristopher Baines <mail@cbaines.net>2023-09-30 10:29:59 +0100
commitd78bbb912c26e6f9329e82e22dd444488cd87979 (patch)
tree7a510fb7566341eab221536fed378a63f67f0f70 /gnu/packages/maths.scm
parentb268842ec4808f5030f3bda95f52ff39dd88e3ad (diff)
gnu: hdf-eos5: Update to 2.0.
* gnu/packages/maths.scm (hdf-eos5): Update to 2.0. [source]: Change URL and add snippet to remove generated files. [native-inputs]: Add autoconf, automake and libtool. [inputs]: Replace hdf5-1.8 with hdf5-1.14. [arguments]: Do not use quasiquote and add the phases remove-single-module-flag and fix-parallel-tests. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm57
1 files changed, 41 insertions, 16 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 91133f721a..efb0f99181 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1741,27 +1741,52 @@ System (Grid, Point and Swath).")
(define-public hdf-eos5
(package
(name "hdf-eos5")
- (version "1.15")
- (source (origin
- (method url-fetch)
- (uri (string-append "ftp://edhs1.gsfc.nasa.gov\
-/edhs/hdfeos5/latest_release/HDF-EOS5." version ".tar.Z"))
- (sha256
- (base32
- "1p83333nzzy8rn5chxlm0hrkjjnhh2w1ji8ac0f9q4xzg838i58i"))
- (patches (search-patches "hdf-eos5-build-shared.patch"
- "hdf-eos5-remove-gctp.patch"
- "hdf-eos5-fix-szip.patch"
- "hdf-eos5-fortrantests.patch"))))
+ (version "2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://git.earthdata.nasa.gov/projects/DAS/repos/hdfeos5/raw/"
+ "hdf-eos5-" version "-src.tar.gz?at=refs/heads/HDFEOS5_" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0by82zznms00b0d5v4iv8a7jff6xm9hzswsx4mfzw2gyy1q4ghyp"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ (for-each delete-file (find-files "." "Makefile\\.in$"))
+ (for-each delete-file (find-files "m4" "^l.*\\.m4$"))
+ (delete-file "configure")
+ (delete-file "aclocal.m4")))))
(native-inputs
- (list gfortran))
+ (list autoconf automake gfortran libtool))
(build-system gnu-build-system)
(inputs
- (list hdf5-1.8 zlib gctp))
+ (list hdf5-1.14 zlib gctp))
(arguments
- `(#:configure-flags '("--enable-install-include" "--enable-shared"
+ (list
+ #:configure-flags ''("--enable-install-include" "--enable-shared"
"CC=h5cc -Df2cFortran" "LIBS=-lgctp")
- #:parallel-tests? #f))
+ #:parallel-tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-single_module-flag
+ (lambda _
+ (substitute* "src/Makefile.am"
+ ((",-single_module") ""))))
+ (add-after 'unpack 'fix-parallel-tests
+ (lambda _
+ (substitute* (find-files "testdrivers" "\\.c$")
+ (("#include <HE5_HdfEosDef.h>" orig)
+ (string-append "#include <HE5_config.h>\n" orig)))
+ ;; pthread is already linked.
+ (substitute* "testdrivers/threads/Makefile.am"
+ (("(LDADD=\\$\\(LIBHDFEOS5\\) \\$\\(LIBGCTP\\)) pthread" _ rest)
+ rest))
+ ;; This file is missing in the testdrivers/threads directory.
+ (copy-file "testdrivers/point/simple.txt"
+ "testdrivers/threads/simple.txt"))))))
(synopsis "HDF5-based data format for NASA's Earth Observing System")
(description
"HDF-EOS5 is a software library built on HDF5 to support the construction