summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-11-04 15:02:37 +0000
committerLudovic Courtès <ludo@gnu.org>2023-12-04 22:26:38 +0100
commiteede7fe00b0ab257281a526fa51ced266fbf5493 (patch)
treea8463dec133a3d999271c6cf3ce563badf0462cc /gnu/packages/maths.scm
parentbe73e08ba2fd8e9280840f8fa962e9821ba5b71e (diff)
gnu: Add python-ndim.
* gnu/packages/maths.scm (python-ndim): New variable. Change-Id: I543f1f5e195f4f2fd5bd70f9ce29ec750a24439b Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 2769c4f6ec..c13be6feb1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -164,6 +164,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
@@ -3691,6 +3692,30 @@ and (dot) products. It implements Kahan summation, Shewchuck's
algorithm and summation in K-fold precision.")
(license license:gpl3+)))
+(define-public python-ndim
+ (package
+ (name "python-ndim")
+ (version "0.1.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/diego-hayashi/ndim")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hri82k7pcpw9dns8l1f2asa3dm7hjv71wnxi3752258ia2qa44v"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-sympy))
+ (native-inputs (list python-flit-core python-pytest))
+ (home-page "https://github.com/diego-hayashi/ndim")
+ (synopsis "Multidimensional volumes and monomial integrals")
+ (description
+ "@code{ndim} computes all kinds of volumes and integrals of
+monomials over such volumes in a fast, numerically stable way, using
+recurrence relations.")
+ (license license:gpl3+)))
+
(define-public slepc
(package
(name "slepc")