summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2023-06-16 15:26:04 +0200
committerLudovic Courtès <ludo@gnu.org>2023-07-13 17:59:57 +0200
commitff208b4b629a15ce0b72555db1cda9fcb7eec1c9 (patch)
tree3892412e057353a47bb5a9b4e642a32f4a9b2ba1 /gnu/packages/maths.scm
parent5594f4c999a71427d7aad9898d7e614b8dbd6b3a (diff)
gnu: arpack-ng: Update to 3.9.0.
* gnu/packages/maths.scm (arpack-ng): Update to 3.9.0. [source]: Add 'patches'. [build-system]: Switch to CMAKE-BUILD-SYSTEM. [native-inputs]: Remove AUTOCONF, AUTOMAKE, and LIBTOOL. (arpack-ng-openmpi)[inputs]: Use 'modify-inputs'. [arguments]: Use gexps. * gnu/packages/patches/arpack-ng-propagate-rng-state.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0d59ff30f7..b0b3e382ae 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -973,7 +973,7 @@ halfspaces) or by their double description with both representations.")
(define-public arpack-ng
(package
(name "arpack-ng")
- (version "3.8.0")
+ (version "3.9.0")
(home-page "https://github.com/opencollab/arpack-ng")
(source (origin
(method git-fetch)
@@ -981,10 +981,11 @@ halfspaces) or by their double description with both representations.")
(file-name (git-file-name name version))
(sha256
(base32
- "0l7as5z6xvbxly8alam9s4kws70952qq35a6vkljzayi4b9gbklx"))))
- (build-system gnu-build-system)
+ "09smxilyn8v9xs3kpx3nlj2s7ql3v8z40mpc09kccbb6smyd35iv"))
+ (patches (search-patches "arpack-ng-propagate-rng-state.patch"))))
+ (build-system cmake-build-system)
(native-inputs
- (list autoconf automake libtool pkg-config))
+ (list pkg-config))
(inputs
(list eigen lapack gfortran))
(synopsis "Fortran subroutines for solving eigenvalue problems")
@@ -998,16 +999,16 @@ large scale eigenvalue problems.")
(package (inherit arpack-ng)
(name "arpack-ng-openmpi")
(inputs
- `(("mpi" ,openmpi)
- ,@(package-inputs arpack-ng)))
+ (modify-inputs (package-inputs arpack-ng)
+ (prepend openmpi)))
(arguments
(substitute-keyword-arguments (package-arguments arpack-ng)
- ((#:configure-flags _ '())
- ''("--enable-mpi"))
- ((#:phases phases '%standard-phases)
- `(modify-phases ,phases
- (add-before 'check 'mpi-setup
- ,%openmpi-setup)))))
+ ((#:configure-flags _ #~())
+ #~'("-DMPI=ON"))
+ ((#:phases phases #~%standard-phases)
+ #~(modify-phases #$phases
+ (add-before 'check 'mpi-setup
+ #$%openmpi-setup)))))
(synopsis "Fortran subroutines for solving eigenvalue problems with MPI")))
(define-public lapack