summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2023-10-05 21:34:58 +0000
committerLudovic Courtès <ludo@gnu.org>2023-10-06 12:26:46 +0200
commite8903490672d3a9e64fab42c40644ffb802ae6d1 (patch)
treebb66674602de86758870c70295f04d8163b29be9 /gnu/packages/maths.scm
parent4b512f54912eba69ea8f21ee6d2f0e7ea608ddbc (diff)
gnu: Add suitesparse-ldl.
* gnu/packages/maths.scm (suitesparse-ldl): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9e52207512..988bf28ac2 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5630,6 +5630,60 @@ direct methods on both real and complex matrices.")
for real and complex matrices.")
(license license:lgpl2.1+)))
+(define-public suitesparse-ldl
+ (package
+ (name "suitesparse-ldl")
+ (version "3.2.0")
+ (source suitesparse-source)
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "LDL")))
+ (add-after 'chdir 'set-cmake-module-path
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("set.*CMAKE_MODULE_PATH.*")
+ (string-append
+ "set(CMAKE_MODULE_PATH "
+ (string-join
+ (map (lambda (path)
+ (string-append path "/lib/cmake/SuiteSparse"))
+ (list #$suitesparse-amd
+ #$suitesparse-config)))
+ ")\nset(DUMMY\n")))))
+ (add-after 'build 'build-doc
+ (lambda _
+ (substitute* "../LDL/Doc/Makefile"
+ (("\\.\\./\\.\\./BTF/Include/btf.h")
+ (string-append #$suitesparse-btf "/include/btf.h")))
+ (with-directory-excursion "../LDL/Doc"
+ (invoke "make"))))
+ (add-after 'install 'install-doc
+ (lambda _
+ (install-file "../LDL/Doc/ldl_userguide.pdf"
+ (string-append #$output "/share/doc/"
+ #$name "-" #$version))))
+ (replace 'install-license-files
+ (lambda _
+ (install-file "../LDL/Doc/License.txt"
+ (string-append #$output "/share/doc/"
+ #$name "-" #$version)))))))
+ (inputs
+ (list suitesparse-amd
+ suitesparse-config))
+ (native-inputs (list (texlive-updmap.cfg '())))
+ (home-page "https://people.engr.tamu.edu/davis/suitesparse.html")
+ (synopsis "LDL' factorization method for sparse, symmetric matrices")
+ (description "This package contains a set of routines for computing the
+LDL' factorization of sparse, symmetric matrices. Its focus lies on concise
+code.")
+ (license license:lgpl2.1+)))
+
(define-public suitesparse
(package
(name "suitesparse")