summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2023-10-12 10:02:25 -0400
committerLudovic Courtès <ludo@gnu.org>2023-10-21 00:27:26 +0200
commitfed6ac2ae182597a492b17a29ed8b26986498755 (patch)
tree085d6d159f779bd4d3143add0ad9358512c7adef /gnu/packages/maths.scm
parentc942f4dcaba8f44d9f89540c22825e935c5acfd1 (diff)
gnu: trilinos-for-dealii-openmpi: Fix build.
This fixes the error error: ‘std::hypot’ has not been declared caused by using an older version of gcc, but requires some patches to placate newer versions of gcc. * gnu/packages/maths.scm (trilinos-for-dealii-openmpi)[origin]: Add patches. [native-inputs]: Remove gcc-7. * gnu/packages/patches/teuchos-remove-duplicate-using.patch: New file. * gnu/packages/patches/tpetra-remove-duplicate-using.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Register them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 8fba8beaa8..5c904fc094 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -6425,13 +6425,13 @@ revised simplex and the branch-and-bound methods.")
(string-replace-substring version "." "-")))))
(file-name (git-file-name "trilinos" version))
(sha256
- (base32 "0fnwlhzsh85qj38cq3igbs8nm1b2jdgr2z734sapmyyzsy21mkgp"))))
+ (base32 "0fnwlhzsh85qj38cq3igbs8nm1b2jdgr2z734sapmyyzsy21mkgp"))
+ (patches
+ (search-patches "teuchos-remove-duplicate-using.patch"
+ "tpetra-remove-duplicate-using.patch"))))
(build-system cmake-build-system)
(native-inputs
(list
- ;; The build fails with the current gcc.
- ;; Use the version from when Trilinos was added.
- gcc-7
gfortran
;; Trilinos's repository contains several C-shell scripts, but adding
;; tcsh to the native inputs does not result in the check phase running