summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-27 21:07:15 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-27 21:07:15 +0200
commit4d42fbd3713dea957eacafab72a29334f30f6367 (patch)
treed1374ae672dd6a239a5f096969a7957e84a6cf9c /gnu/packages/maths.scm
parentecb4f4d01518ea011e64d85ea7cffd7c173c9e01 (diff)
gnu: sleef: Adjust inputs.
* gnu/packages/maths.scm (sleef)[inputs]: Replace openssl with openssl-1.1; remove mpfr. [arguments]: Remove custom phase 'make-git-checkout-writable; use G-expression for configure-flags.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm25
1 files changed, 8 insertions, 17 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9ac365fbb4..f69d59273a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2014-2022 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2014 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2014 Mathieu Lirzin <mathieu.lirzin@openmailbox.org>
-;;; Copyright © 2015–2022 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015–2023 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015-2022 Efraim Flashner <efraim@flashner.co.il>
@@ -735,23 +735,14 @@ numbers.")
(base32 "1jybqrl2dvjxzg30xrhh847s375n2jr1pix644wi6hb5wh5mx3f7"))))
(build-system cmake-build-system)
(arguments
- '(#:configure-flags (list "-DCMAKE_BUILD_TYPE=Release"
- (string-append "-DCMAKE_INSTALL_LIBDIR="
- (assoc-ref %outputs "out")
- "/lib")
- (string-append "-DCMAKE_INSTALL_PREFIX="
- (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- ;; SLEEF generates a header library during the build process and writes
- ;; to it via shell redirection. Make the checkout writable so the
- ;; build can succeed.
- (add-after 'unpack 'make-git-checkout-writable
- (lambda _
- (for-each make-file-writable (find-files "."))
- #t)))))
+ (list
+ #:configure-flags
+ #~(list "-DCMAKE_BUILD_TYPE=Release"
+ (string-append "-DCMAKE_INSTALL_LIBDIR=" #$output "/lib")
+ (string-append "-DCMAKE_INSTALL_PREFIX=" #$output))))
+ ;; XXX: Removed mpfr because of https://github.com/shibatch/sleef/issues/458
(inputs
- (list fftw gmp mpfr openssl))
+ (list fftw gmp openssl-1.1))
(home-page "https://sleef.org/")
(synopsis "SIMD library for evaluating elementary functions and DFT")
(description