summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-11-06 00:51:44 +0100
committerLudovic Courtès <ludo@gnu.org>2023-11-23 12:56:42 +0100
commit5b910b4f7cf5f994d42fffb107109808678b706c (patch)
tree550c906f4bbfd6f3e81375eff7d6210b73c58052 /gnu/packages/maths.scm
parent267786721b64c11343d9f96fde21d79a07655bf3 (diff)
gnu: scilab: Remove uneeded code.
* gnu/packages/maths.scm (scilab): [source](snippet): Remove directory Visual-Studio-settings and file Scilab.sln. [arguments](configure-flags): Remove uneeded FFLAGS environment variable set. [arguments](phases): prebuild: Remove uneeded SCIHOME setting code. Change-Id: I71c044e19617bf556bbe95e7ba0cdbd716921055 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 34710fc65c..750de949b7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9559,7 +9559,8 @@ computation is supported via MPI.")
(for-each delete-file-recursively
'("scilab"
"config"
- "libs/GetWindowsVersion"))
+ "libs/GetWindowsVersion"
+ "Visual-Studio-settings"))
(for-each delete-file
(cons* "aclocal.m4"
"configure"
@@ -9571,6 +9572,7 @@ computation is supported via MPI.")
"m4/ltversion.m4"
"m4/lt~obsolete.m4"
"m4/pkg.m4"
+ "Scilab.sln"
(find-files "." "^Makefile\\.in$")))
;; And finally some files in the modules directory:
@@ -9654,10 +9656,7 @@ computation is supported via MPI.")
(search-input-directory %build-inputs "include/eigen3"))
;; Find and link to the OCaml Num package
"OCAMLC=ocamlfind ocamlc -package num"
- "OCAMLOPT=ocamlfind ocamlopt -package num -linkpkg"
- ;; There are some 2018-fortran errors that are ignored
- ;; with this fortran compiler flag.
- "FFLAGS=-fallow-argument-mismatch")
+ "OCAMLOPT=ocamlfind ocamlopt -package num -linkpkg")
#:phases
#~(modify-phases %standard-phases
;; The Num library is specified with the OCAMLC and
@@ -9685,14 +9684,12 @@ computation is supported via MPI.")
(lambda* (#:key inputs #:allow-other-keys)
;; Fix scilab script.
(substitute* "bin/scilab"
- (("\\/bin\\/ls")
+ (("/bin/ls")
(search-input-file inputs "bin/ls")))
;; Fix core.start.
(substitute* "modules/core/etc/core.start"
(("'SCI/modules")
- "SCI+'/modules"))
- ;; Set SCIHOME to /tmp before macros compilation.
- (setenv "SCIHOME" "/tmp")))
+ "SCI+'/modules"))))
;; Prevent race condition
(add-after 'pre-build 'build-parsers
(lambda* (#:key (make-flags #~'()) #:allow-other-keys)