summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-02 18:22:26 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-02 19:11:14 +0200
commit005c787d5983858ee0313cbb03bfae1f52e9254b (patch)
treec857783ed13237899faf67f0a9f8b05ab02b4f65 /gnu/packages/maths.scm
parent7cd9b0140767f713c289cc2fb9a6c28777384091 (diff)
gnu: Add IpOpt.
* gnu/packages/maths.scm (ipopt): New variable.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e11208c32e..7281e43adc 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -582,6 +582,37 @@ common interface for a number of different free optimization routines available
online as well as original implementations of various other algorithms.")
(license license:lgpl2.1+)))
+(define-public ipopt
+ (package
+ (name "ipopt")
+ (version "3.12.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.coin-or.org/download/source/Ipopt/Ipopt-"
+ version".tgz"))
+ (sha256
+ (base32
+ "09bk2hqy2vgi4yi76xng9zxakddwqy3wij9nx7wf2vfbxxpazrsk"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Make sure we don't use the bundled software.
+ '(delete-file-recursively "ThirdParty"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gfortran" ,gfortran)))
+ (inputs
+ ;; TODO: Maybe add dependency on COIN-MUMPS, ASL, and HSL.
+ `(("blas" ,openblas)
+ ("lapack" ,lapack)))
+ (home-page "http://www.coin-or.org")
+ (synopsis "Large-scale nonlinear optimizer")
+ (description
+ "The Interior Point Optimizer (IPOPT) is a software package for
+large-scale nonlinear optimization. It provides C++, C, and Fortran
+interfaces.")
+ (license license:epl1.0)))
+
;; For a fully featured Octave, users are strongly recommended also to install
;; the following packages: texinfo, less, ghostscript, gnuplot.
(define-public octave