summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-24 21:25:52 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-24 21:25:52 +0100
commitaa51eb2073f17e40d660d0beaeb7b1b78aa9e1cc (patch)
tree5ccb7f83712c4400176a344e537b5fcbbb7047aa /gnu/packages/maths.scm
parent1b9eb93a5dd1e90291b614311cd1fb2051e72718 (diff)
parent6eb35d4a780d37b809a6c8c1794ff227da2fa29d (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c3587007df..de0308bb0a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -428,15 +428,17 @@ LP/MIP solver is included in the package.")
(define-public 4ti2
(package
(name "4ti2")
- (version "1.6.7")
+ (version "1.6.9")
(source
(origin
- (method url-fetch)
- (uri (string-append "http://www.4ti2.de/version_" version
- "/4ti2-" version ".tar.gz"))
- (sha256
- (base32
- "1frix3rnm9ffr93alqzw4cavxbfpf524l8rfbmcpyhwd3n1km0yl"))))
+ (method url-fetch)
+ (uri (string-append "https://github.com/4ti2/4ti2/releases/download/"
+ "Release_"
+ (string-map (lambda (c) (if (char=? c #\.) #\_ c))
+ version)
+ "/4ti2-" version ".tar.gz"))
+ (sha256
+ (base32 "0rj92x6p9m3la5gasjbj7sa569im527ffmka5y2sv1amgd3fflrh"))))
(build-system gnu-build-system)
(native-inputs
`(("which" ,(@ (gnu packages base) which)))) ; for the tests