summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:17:44 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:38 +0200
commitca72dd2cb52f9de6fb2fd4aff527db22ff438032 (patch)
tree391a2d4021fa75e8bd4e0c6942e3552404bb6f07 /gnu/packages/maths.scm
parent830971bf3aedcd389451d45e4ff8f7c6616d316f (diff)
gnu: openlibm: Don't use unstable tarball.
* gnu/packages/maths.scm (openlibm)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0c0dc24b3f..3f8b095b6a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3143,13 +3143,13 @@ access to BLIS implementations via traditional BLAS routine calls.")
(version "0.6.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/JuliaLang/openlibm/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaLang/openlibm.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0a5fpm8nra5ldhjk0cqd2rx1qh32wiarkxmcqcm5xl8z7l4kjm6l"))))
+ (base32 "08wfchmmr5200fvmn1kwq9byc1fhsq46hn0y5k8scdl74771c7gh"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags