summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-07-20 15:05:55 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-30 17:47:54 +0100
commit8a637e79ed6410f093a040f788708b2cf8678bbf (patch)
treea573f2c999739f81e49f6c552aa9c35e38754df0 /gnu/packages/maths.scm
parentb90e7e5d49e951a24f58d3cd29d37127982ef240 (diff)
gnu: openblas: Set TARGET to SICORTEX on MIPS.
* gnu/packages/maths.scm (openblas)[arguments]: Add "TARGET=SICORTEX" to make-flags when building for MIPS.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4935f8019f..b5abc48b36 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1491,10 +1491,16 @@ constant parts of it.")
;; Unfortunately, this is not supported on non-x86 architectures,
;; where it leads to failed builds.
,@(let ((system (or (%current-target-system) (%current-system))))
- (if (or (string-prefix? "x86_64" system)
+ (cond
+ ((or (string-prefix? "x86_64" system)
(string-prefix? "i686" system))
- '("DYNAMIC_ARCH=1")
- '())))
+ '("DYNAMIC_ARCH=1"))
+ ;; On MIPS we force the "SICORTEX" TARGET, as for the other
+ ;; two available MIPS targets special extended instructions
+ ;; for Loongson cores are used.
+ ((string-prefix? "mips" system)
+ '("TARGET=SICORTEX"))
+ (else '()))))
;; no configure script
#:phases (alist-delete 'configure %standard-phases)))
(inputs