summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-21 12:37:23 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-21 15:47:40 +0100
commitb15e47f9e6dd069ae237ee337207a636fffb407e (patch)
tree2b8d1d1274ef5dfc9b29ded859f8fb34624de7ed /gnu/packages/maths.scm
parentb1186502a4851a11b79232430c99ad03252ae1c3 (diff)
gnu: Add armadillo.
* gnu/packages/maths.scm (armadillo): New variable.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0c0f013ca4..0d66b9fc69 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1422,6 +1422,35 @@ output to TeX, and a browser for Maxima's manual including command index and
full text searching.")
(license license:gpl2+)))
+(define-public armadillo
+ (package
+ (name "armadillo")
+ (version "6.400.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/arma/armadillo-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0bsgrmldlx77w5x26n3axj1hg6iw6csyw0dwl1flrbdwl51f9701"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ;no test target
+ (inputs
+ `(("openblas" ,openblas)
+ ("lapack" ,lapack)
+ ("arpack" ,arpack-ng)))
+ (home-page "http://arma.sourceforge.net/")
+ (synopsis "C++ linear algebra library")
+ (description
+ "Armadillo is a C++ linear algebra library, aiming towards a good balance
+between speed and ease of use. It is useful for algorithm development
+directly in C++, or quick conversion of research code into production
+environments. It can be used for machine learning, pattern recognition,
+signal processing, bioinformatics, statistics, econometrics, etc. The library
+provides efficient classes for vectors, matrices and cubes, as well as 150+
+associated functions (eg. contiguous and non-contiguous submatrix views).")
+ (license license:mpl2.0)))
+
(define-public muparser
(package
(name "muparser")