summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-04-27 11:09:07 +0200
committerAndreas Enge <andreas@enge.fr>2014-04-27 11:35:26 +0200
commit06ed59825ecc0dc78d4d16d06c129e2f4879201a (patch)
tree6e0efd0e943bf012d0b1127c9d1bf7fcad96b36c /gnu/packages/maths.scm
parent5d17cf8eb96e7f266c3ec8d9e512389d1875401b (diff)
guix: cmake: Add input and package libraries to the rpath, and adapt package
definitions accordingly. * guix/build/cmake-build-system.scm (configure): Add flags. * gnu/packages/maths.scm (lapack): Drop special code. * gnu/packages/ssh.scm (libssh): Drop special code. * gnu/packages/slim.scm (slim): Drop special code and enable shared library. Co-authored-by: Eric Bavier <bavier@member.fsf.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm35
1 files changed, 3 insertions, 32 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 68c326752c..232b79b312 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;;
@@ -190,43 +190,14 @@ output in text, PostScript, PDF or HTML.")
(inputs `(("fortran" ,gfortran-4.8)
("python" ,python-2)))
(arguments
- `(#:modules ((guix build cmake-build-system)
- (guix build utils)
- (guix build rpath)
- (srfi srfi-1))
- #:imported-modules ((guix build cmake-build-system)
- (guix build gnu-build-system)
- (guix build utils)
- (guix build rpath))
- #:configure-flags '("-DBUILD_SHARED_LIBS:BOOL=YES")
+ `(#:configure-flags '("-DBUILD_SHARED_LIBS:BOOL=YES")
#:phases (alist-cons-before
'check 'patch-python
(lambda* (#:key inputs #:allow-other-keys)
(let ((python (assoc-ref inputs "python")))
(substitute* "lapack_testing.py"
(("/usr/bin/env python") python))))
- (alist-cons-after
- 'strip 'add-libs-to-runpath
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (fortran (assoc-ref inputs "fortran"))
- (libc (assoc-ref inputs "libc"))
- (rpaths `(,(string-append fortran "/lib64")
- ,(string-append fortran "/lib")
- ,(string-append libc "/lib")
- ,(string-append out "/lib"))))
- ;; Set RUNPATH for all libraries
- (with-directory-excursion out
- (for-each
- (lambda (lib)
- (let ((lib-rpaths (file-rpath lib)))
- (for-each
- (lambda (dir)
- (or (member dir lib-rpaths)
- (augment-rpath lib dir)))
- rpaths)))
- (find-files "lib" ".*so$")))))
- %standard-phases))))
+ %standard-phases)))
(synopsis "Library for numerical linear algebra")
(description
"LAPACK is a Fortran 90 library for solving the most commonly occurring