summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-15 15:21:15 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-11-15 15:21:15 +0200
commitf5a077b10f7e073b9242cfada78a1d8b8e920e3e (patch)
tree11f42608267f28c3f0720ace5ba8c5084e3c6f31 /gnu/packages/maths.scm
parentfccab9931cdde00a7d308c29458af5c65d977375 (diff)
gnu: octave: Update to 4.2.0.
* gnu/packages/maths.scm (octave): Update to 4.2.0. [native-inputs]: Add lzip. [home-page]: Use https.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f7a4bbe75f..a1bd7846f8 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -891,15 +891,15 @@ can solve two kinds of problems:
(define-public octave
(package
(name "octave")
- (version "4.0.3")
+ (version "4.2.0")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://gnu/octave/octave-"
- version ".tar.xz"))
+ version ".tar.lz"))
(sha256
(base32
- "11day29k4yfvxh4101x5yf26ld992x5n6qvmhjjk6mzsd26fqayw"))))
+ "19vvliwxgip0af812vny5xy5r8kacyj7v62203mh4z2n3p14b78i"))))
(build-system gnu-build-system)
(inputs
`(("lapack" ,lapack)
@@ -918,7 +918,8 @@ can solve two kinds of problems:
("glu" ,glu)
("zlib" ,zlib)))
(native-inputs
- `(("gfortran" ,gfortran)
+ `(("lzip" ,lzip)
+ ("gfortran" ,gfortran)
("pkg-config" ,pkg-config)
("perl" ,perl)
;; The following inputs are not actually used in the build process.
@@ -937,7 +938,7 @@ can solve two kinds of problems:
(list (string-append "--with-shell="
(assoc-ref %build-inputs "bash")
"/bin/sh"))))
- (home-page "http://www.gnu.org/software/octave/")
+ (home-page "https://www.gnu.org/software/octave/")
(synopsis "High-level language for numerical computation")
(description "GNU Octave is a high-level interpreted language that is
specialized for numerical computations. It can be used for both linear and