summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-05-19 11:47:27 +0200
committerLudovic Courtès <ludo@gnu.org>2016-05-19 14:51:21 +0200
commit39b3033731283b81ae36f022c6476634ab1d0455 (patch)
treeb503b38b0c03ea7face3df6e1fa632db3330ee45 /gnu/packages/maths.scm
parent0947698c42fb10b8802679cbc58f9a42a2d91043 (diff)
gnu: flann: Strip .mex file.
* gnu/packages/maths.scm (flann)[arguments]: Add #:strip-directories.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 2926c1c4c9..da7bfa6b76 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2015 Fabian Harfert <fhmgufs@web.de>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
+;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2208,7 +2209,12 @@ in finite element programs.")
;; ("python2-numpy" ,python2-numpy) ; only required for the tests
("zlib" ,zlib)))
(arguments
- `(#:tests? #f)) ; The test data are downloaded from the Internet.
+ `(;; The 'share/flann/octave' contains a .mex file, which is an ELF file
+ ;; taken 46 MiB unstripped, and 6 MiB stripped.
+ #:strip-directories '("lib" "lib64" "libexec"
+ "bin" "sbin" "share/flann/octave")
+
+ #:tests? #f)) ; The test data are downloaded from the Internet.
(home-page "http://www.cs.ubc.ca/research/flann/")
(synopsis "Library for approximate nearest neighbors computation")
(description "FLANN is a library for performing fast approximate