summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-04-15 10:39:54 -0500
committerEric Bavier <bavier@member.fsf.org>2016-05-12 19:59:52 +0000
commitb8d9c93bde155af13e633f8b84b56372c2044c43 (patch)
tree3e20faaf2f616e978fb6879319f82bd0d1cfaa4e /gnu/packages/maths.scm
parentf622e2123b578d9fea6d967a69492cc2041ce348 (diff)
gnu: hdf5: Have configure honor SOURCE_DATE_EPOCH.
* gnu/packages/patches/hdf5-config-date.patch: New patch. * gnu/packages/maths.scm (hdf5)[source]: Use it. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4a10f6feb0..df21d5ea5b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -414,7 +414,8 @@ plotting engine by third-party applications like Octave.")
version "/src/hdf5-"
version ".tar.bz2"))
(sha256
- (base32 "0sj8x0gfs5fb28gipnynb9wpkz113h8wq9sva9mxx66kv27xsdgw"))))
+ (base32 "0sj8x0gfs5fb28gipnynb9wpkz113h8wq9sva9mxx66kv27xsdgw"))
+ (patches (list (search-patch "hdf5-config-date.patch")))))
(build-system gnu-build-system)
(inputs
`(("zlib" ,zlib)))
@@ -424,7 +425,8 @@ plotting engine by third-party applications like Octave.")
(add-before 'configure 'patch-configure
(lambda _
(substitute* "configure"
- (("/bin/mv") "mv"))))
+ (("/bin/mv") "mv"))
+ #t))
(add-after 'install 'patch-references
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((bin (string-append (assoc-ref outputs "out") "/bin"))