summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorJean-Baptiste Volatier <jbv@pm.me>2021-07-22 12:34:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-28 16:05:31 +0300
commit1978d716a97547d2768dbf50438388e31b1acc5e (patch)
tree4cc4b9e4a77b4b2b67cca32f094c76c7d4830fb4 /gnu/packages/maths.scm
parent4709b74bc86c2a23c27c698776595e0323dea658 (diff)
gnu: openlibm: Fix cross-compiling.
* gnu/packages/maths.scm (openlibm)[arguments]: Add configure-flag to use cc-for-target. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 05c92ce617..d4e3aca21e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4198,7 +4198,8 @@ access to BLIS implementations via traditional BLAS routine calls.")
(build-system gnu-build-system)
(arguments
`(#:make-flags
- (list (string-append "prefix=" (assoc-ref %outputs "out")))
+ (list (string-append "prefix=" (assoc-ref %outputs "out"))
+ ,(string-append "CC=" (cc-for-target)))
#:phases
;; no configure script
(modify-phases %standard-phases (delete 'configure))