summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:01 +0200
commit24d4e8182d0cb783d39240e0af4ee5dbf999593f (patch)
tree70e45f4ec01bfdb4aacf6294089eedf274f97766 /gnu/packages/maths.scm
parentd6cb55b395cb2e613a26c1acceee3c8623ee5baf (diff)
gnu: vc: Use G-expressions.
* gnu/packages/maths.scm (vc)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 12d802268e..8c30e49d8f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5942,18 +5942,19 @@ supports compressed MAT files, as well as newer (version 7.3) MAT files.")
(base32 "0zq37r8yisd4dwlb024l10wk2yq9kisa4xm79ia1ggrz7w2s13lq"))))
(build-system cmake-build-system)
(arguments
- '(#:configure-flags
- '("-DBUILD_TESTING=ON"
- ;; By default, Vc will optimize for the CPU of the build machine.
- ;; Setting this to "none" makes it create portable binaries. See
- ;; "cmake/OptimizeForArchitecture.cmake".
- "-DTARGET_ARCHITECTURE=none")
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'copy-testdata
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
- (let ((testdata (assoc-ref (or native-inputs inputs)
- "testdata")))
- (copy-recursively testdata "tests/testdata")))))))
+ (list
+ #:configure-flags
+ #~(list "-DBUILD_TESTING=ON"
+ ;; By default, Vc will optimize for the CPU of the build machine.
+ ;; Setting this to "none" makes it create portable binaries. See
+ ;; "cmake/OptimizeForArchitecture.cmake".
+ "-DTARGET_ARCHITECTURE=none")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'copy-testdata
+ (lambda _
+ (copy-recursively #$(this-package-native-input "testdata")
+ "tests/testdata"))))))
(native-inputs
`(("virtest" ,virtest)