summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-19 09:30:19 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-27 16:33:32 +0200
commit7f07441b1734cc218dc1831e5a77d60771de83a2 (patch)
tree70b7989501aeea5965fa38e17771fbdd8fa79bb6 /gnu/packages/maths.scm
parent8a7860d9d860b8558558d82d252b12be8e8acadd (diff)
gnu: Add popf.
* gnu/packages/maths.scm (popf): New variable.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 3c511bd77c..ed1708c77b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3180,6 +3180,54 @@ This is the certified version of the Open Cascade Technology (OCCT) library.")
supports the propositional fragment of PDDL2.2.")
(license license:gpl3+)))
+(define-public popf
+ (package
+ (name "popf")
+ (version "0.0.15")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fmrico/popf")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1i1am3h6japn8fgapi5s5mnyrm31a05jkjhzgk48cd2n42c5060v"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-cmake
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* (find-files "." "CMakeLists\\.txt")
+ (("/usr/local/opt/flex/include")
+ (dirname (search-input-file inputs "include/FlexLexer.h"))))
+ (substitute* "CMakeLists.txt"
+ (("find_package\\(ament_cmake REQUIRED\\)") "")
+ (("ament_.*") "")
+ (("(RUNTIME DESTINATION) .*" all dst)
+ (string-append dst " libexec/${PROJECT_NAME}")))))
+ (add-after 'install 'symlink
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (mkdir-p (string-append out "/bin"))
+ (for-each (lambda (link)
+ (symlink
+ (string-append out "/libexec/popf/" (cdr link))
+ (string-append out "/bin/" (car link))))
+ '(("popf" . "popf") ("VAL" . "validate")))))))))
+ (inputs (list cbc flex))
+ (native-inputs (list flex bison perl))
+ (home-page "https://github.com/fmrico/popf")
+ (synopsis "Forward-chaining temporal planner")
+ (description "This package contains an implementation of the @acronym{POPF,
+Partial Order Planning Forwards} planner described in @cite{Forward-Chaining
+Partial Order Planning}, that has been updated to compile with newer C++
+compilers.")
+ (license license:gpl2+)))
+
(define-public gmsh
(package
(name "gmsh")