summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-14 15:46:33 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-14 15:49:56 +0200
commit921595fa65db00aacb5dc3cceda89359e25322f4 (patch)
treeff4de42d71e40b5beef88af678424dacedb76b42 /gnu/packages/maths.scm
parent49ab267cbec17643e265305c109dc397b5e43cf5 (diff)
gnu: gsl: Comment out more tests that fail on i686-linux.
* gnu/packages/maths.scm (gsl)[arguments]: In 'disable-failing-tests' phase, comment out more tests.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index b6fd5c9354..3672048ef2 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -552,12 +552,21 @@ precision floating point numbers.")
(substitute* "linalg/test.c"
((".*gsl_test\\(test_LU_decomp.*") "\n")
((".*gsl_test\\(test_LUc_decomp.*") "\n")
+ ((".*gsl_test\\(test_QR_decomp_r.*") "\n")
((".*gsl_test\\(test_cholesky_decomp.*") "\n")
+ ((".*gsl_test\\(test_pcholesky_solve.*") "\n")
((".*gsl_test\\(test_COD_lssolve2.*") "\n"))
(substitute* "spmatrix/test.c"
((".*test_all.*") "\n")
((".*test_float.*") "\n")
- ((".*test_complex.*") "\n"))))))
+ ((".*test_complex.*") "\n"))
+
+ ;; XXX: These tests abort with:
+ ;; gsl: cholesky.c:645: ERROR: matrix is not positive definite
+ (substitute* '("multifit_nlinear/test.c"
+ "multilarge_nlinear/test.c")
+ (("gsl_ieee_env_setup.*" all)
+ (string-append "exit (77);\n" all)))))))
(else '()))))))
(home-page "https://www.gnu.org/software/gsl/")