summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2023-10-05 21:34:51 +0000
committerLudovic Courtès <ludo@gnu.org>2023-10-06 12:26:45 +0200
commit998a79355c2ad5ce6251d0b29896c3fbcc4b4973 (patch)
treec0f09838529b519aba43291f1471415e243d943c /gnu/packages/maths.scm
parenta764c7c0b91f20a0e3cb11fcf778965d3b1f6c2c (diff)
gnu: Add gklib.
* gnu/packages/maths.scm (gklib): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 30d6351a0a..cef899fc8a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4344,6 +4344,42 @@ bio-chemistry.")
(define-public pt-scotch-shared
(deprecated-package "pt-scotch-shared" pt-scotch))
+(define-public gklib
+ (let ((commit "8bd6bad750b2b0d90800c632cf18e8ee93ad72d7")
+ (revision "1"))
+ (package
+ (name "gklib")
+ (version (git-version "5.1.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KarypisLab/GKlib")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08k4zzyd7zsisdhfmnwz7zb9w3pzpgagyjq52mwk8i6sqajdxsdn"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "-DBUILD_SHARED_LIBS=ON"
+ #$@(if (target-x86?)
+ '()
+ '("-DNO_X86=1")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-march=native
+ (lambda _
+ (substitute* "GKlibSystem.cmake"
+ (("-march=native") "")))))))
+ (home-page "https://github.com/KarypisLab/GKlib")
+ (synopsis "Helper library for METIS")
+ (description
+ "GKlib is a library of various helper routines and frameworks used by
+software from KarypisLab, such as METIS.")
+ (license license:asl2.0))))
(define-public metis
(package