summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-11-04 15:02:38 +0000
committerLudovic Courtès <ludo@gnu.org>2023-12-04 22:26:38 +0100
commitd3ed7bb5e311502d43ccca95ef9032dcde76c911 (patch)
treeed626f72e1020882cb6f01647a70d838f7b57e14 /gnu/packages/maths.scm
parenteede7fe00b0ab257281a526fa51ced266fbf5493 (diff)
gnu: Add python-orthopy.
* gnu/packages/maths.scm (python-orthopy): New variable. Change-Id: I75e528f30d285666b8012a9cbc5cbb7e28aaf764 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c13be6feb1..9363c536c2 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -174,6 +174,7 @@
#:use-module (gnu packages scheme)
#:use-module (gnu packages serialization)
#:use-module (gnu packages shells)
+ #:use-module (gnu packages simulation)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages swig)
@@ -3716,6 +3717,47 @@ monomials over such volumes in a fast, numerically stable way, using
recurrence relations.")
(license license:gpl3+)))
+(define-public python-orthopy
+ (package
+ (name "python-orthopy")
+ (version "0.9.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/diego-hayashi/orthopy")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00s2rwjdlq38zkf7wl1gvm2aw057r30266lkzfxkrfzr4i705xnq"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-importlib-metadata
+ python-ndim
+ python-numpy
+ python-sympy))
+ (native-inputs (list ;python-cplot ;only used in deselected tests
+ python-matplotx
+ python-meshio
+ python-meshzoo
+ python-pytest
+ python-scipy))
+ (arguments
+ (list
+ #:test-flags
+ ;; These tests fails with unexpected keyword arguments
+ ;; in calls to cplot.
+ #~(list "--deselect" "tests/test_u3.py::test_write_single"
+ "--deselect" "tests/test_u3.py::test_write_tree")))
+ (home-page "https://github.com/diego-hayashi/orthopy")
+ (synopsis "Tools for orthogonal polynomials, Gaussian quadrature")
+ (description "@code{orthopy} provides various orthogonal polynomial
+classes for lines, triangles, quadrilaterals, disks, spheres, hexahedra,
+and n-cubes. All computations are done using numerically stable
+recurrence schemes. Furthermore, all functions are fully vectorized and
+can return results in exact arithmetic.")
+ (license license:gpl3+)))
+
(define-public slepc
(package
(name "slepc")