summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-08 18:42:00 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-08 18:56:53 +0100
commit77c8382bb67bd334b3907c246ee064cda4b771ce (patch)
treef028d59aebf5592eae7bed270f83dfeb61c2862a /gnu/packages/maths.scm
parent3867cb7885d72f07cb34479738b4746443ca5b92 (diff)
gnu: mumps: Allow compilation with GCC 10.
Following the suggestion at <https://community.freefem.org/t/compline-on-macos-10-15-6/543>. * gnu/packages/maths.scm (mumps)[arguments]: In 'configure' phase, add '-fallow-argument-mismatch' to 'OPTF'.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ea374a4f4c..b025ace4bb 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3488,7 +3488,7 @@ SCALAP = -Wl,-rpath=$(SCALAPDIR) -Wl,-rpath='$$ORIGIN' -L$(SCALAPDIR) -lsc
LIBOTHERS = -pthread
CDEFS = -DAdd_
PIC = -fPIC
-OPTF = -O2 -DALLOW_NON_INIT $(PIC)
+OPTF = -O2 -DALLOW_NON_INIT -fallow-argument-mismatch $(PIC)
OPTL = -O2 $(PIC)
OPTC = -O2 $(PIC)
INCS = $(INCSEQ)